Jump to content





News Feed (View All Updates)


Photo

Mondeo 2003 2.0 tdci zetec cutting out.


  • Please log in to reply
22 replies to this topic

#1 justinkeeton

justinkeeton

    Just Joined TF!

  • Members
  • 3 posts
  • 0 thanks
  • Vehicle Driven:ford mondeo
  • Location:sheffield

Posted 27 September 2010 - 06:01 PM

can anybody help, I've just bought the above car. It runs perfect but it has cut out completely whilst driving. When it cut out the glow plug light came on. Once Id come to a stop the car started straight away. Think this could be some sort of electrical prob, has anybody had this problem and knows what it is?

#2 Mabok01

Mabok01

    Old Fords never die they just keep on rolling.

  • Members
  • 3,004 posts
  • 258 thanks
  • Vehicle Driven:Mondeo TDCI 130 2004
  • Name:Michael
  • Location:Londonderry

Posted 27 September 2010 - 06:35 PM

Hi Justin.

Welcome to Talkford.

Unfortunately the flashing glowplug light is often just an indication as to the fact that you have a problem. I would recommend getting the fault codes read if you also have the Engine Malfunction Light lit as well.

There are a load of things that could cause this. Did the car go into limp mode or cut out completely? Have you had the fuel filter changed recently? We need as much information as possible to help you find an answer.

2004 Hatchback 130 TDCI Inkblue Mileage 443.000 Miles.

Genuine Ford fuel pump sprocket locking tool and pump mounting bolt tool for rent. Refundable deposit by Paypal required.

 


#3 justinkeeton

justinkeeton

    Just Joined TF!

  • Members
  • 3 posts
  • 0 thanks
  • Vehicle Driven:ford mondeo
  • Location:sheffield

Posted 27 September 2010 - 10:02 PM

Hi Justin.

Welcome to Talkford.

Unfortunately the flashing glowplug light is often just an indication as to the fact that you have a problem. I would recommend getting the fault codes read if you also have the Engine Malfunction Light lit as well.

There are a load of things that could cause this. Did the car go into limp mode or cut out completely? Have you had the fuel filter changed recently? We need as much information as possible to help you find an answer.



Hi,

thanks for the speedy reply.

It was just the glow pluf light that was on and the car cut out completely. The car is new to me so not sure whether it has had the fuel filter changed recently or not.

Cheers

Justin

#4 Mabok01

Mabok01

    Old Fords never die they just keep on rolling.

  • Members
  • 3,004 posts
  • 258 thanks
  • Vehicle Driven:Mondeo TDCI 130 2004
  • Name:Michael
  • Location:Londonderry

Posted 27 September 2010 - 10:17 PM

A new fuel filter has cured glowplug flashing for a few people on here as has cleaning the EGR valve and inlet manifold for others. It really is hard to say what has caused it. Cleaning the EGR etc is a free if messy way to try and fix it.

Has it happened more than once?

2004 Hatchback 130 TDCI Inkblue Mileage 443.000 Miles.

Genuine Ford fuel pump sprocket locking tool and pump mounting bolt tool for rent. Refundable deposit by Paypal required.

 


#5 markderby

markderby

    Derby Meets Organiser

  • Members
  • 3,829 posts
  • 57 thanks
  • Vehicle Driven:Modifide TDCI
  • Location:derbyshire

Posted 28 September 2010 - 07:53 AM

A new fuel filter has cured glowplug flashing for a few people on here as has cleaning the EGR valve and inlet manifold for others. It really is hard to say what has caused it. Cleaning the EGR etc is a free if messy way to try and fix it.

Has it happened more than once?



it all so could be the Cam sensor this would make the engine cut out random and give the engine/coil light

Mondeo Mk3 Ghia X TDCI StarDust Silver Facelift Zetec-S/ST Body Kit My Car Pics
Methanol/Water Injection & Nitrous Oxcide Wheel Power 227bhp / 341lb-ft or 462NM Flywheel Power 266bhp / 388lb-ft or 526NM
Modifide injectors, Big Intercooler, Stainless Steel Decat & Exhaust System ,Forge Pipe Set R-Tech Tuning Custom Ice Install


#6 Lee_TDCi

Lee_TDCi

    Megger

  • Members
  • 131 posts
  • 0 thanks
  • Vehicle Driven:Mk3 Mondeo 155 TDCi
  • Location:somerset

Posted 28 September 2010 - 07:08 PM

it all so could be the Cam sensor this would make the engine cut out random and give the engine/coil light



+1

Get the code read before you cut out waiting to pull out at a roundabout, in rush hour traffic, in the single occupancy lane. I speak from bitter experience, it never happens on a quiet bit of road when you have all the time in the world!
Fiat Punto mk2 JTD HLX 80
Ford Mondeo Mk3 Zetec TDCi 130
Ford Mondeo Mk3 155 Edge

#7 justinkeeton

justinkeeton

    Just Joined TF!

  • Members
  • 3 posts
  • 0 thanks
  • Vehicle Driven:ford mondeo
  • Location:sheffield

Posted 28 September 2010 - 07:49 PM

it all so could be the Cam sensor this would make the engine cut out random and give the engine/coil light


Thanks for the replies, were abouts is the EGR valve located as my cousin who's a mechanic will be having a look at the car for me.

Cheers

Justin

#8 mondeonz

mondeonz

    Member-at-Large, Extraordinary and Plenipotentiary

  • Members
  • 508 posts
  • 31 thanks
  • Vehicle Driven:Mondeo Mk4.5 TDCI
  • Location:Australia

Posted 28 September 2010 - 08:03 PM

Hi Justin

1st of all congrats on the new Mondy.
As for EGR location and how to, look at http://fordwiki.co.u...d_Clearout_TDCi

I'd start with a new fuel filter and a bottle of Valvoline Synpower Diesel Fuel System cleaner (black 330ml bottle with white sticker) on a full tank.
Following that, I' d do the cam sensor check, EGR cleanout, etc...

Good Luck
Mondeo Mk3 09/2005 TDCi 130 Turnier Carving (+CH), DuraShift 5-tronic, Diamond White
Mondeo Mk4.5 06/2011 2.0 TDCi 163, Wagon ZETEC (+AUS), PowerShift, Panther Black
Focus Mk3 09/2012 1.6 Ti-VCT 125, Hatch Ambiente (+AUS), 5-speed manual, Ingot Silver

#9 salta

salta

    MEG Corporal

  • Members
  • 5,560 posts
  • 372 thanks

Posted 29 September 2010 - 12:57 PM

can anybody help, I've just bought the above car. It runs perfect but it has cut out completely whilst driving. When it cut out the glow plug light came on. Once Id come to a stop the car started straight away. Think this could be some sort of electrical prob, has anybody had this problem and knows what it is?


the words cut out compleetly mean a compleete failure on all four cylinders.therre are very few reasons which cause this ..total seizure due to no oil or brokenn engine..or what i consider happened your car an electricial failure causing the cut off solinoid on the injector pump to opperate as in when you swith off the ignition switch to shut down the engine.this is a serious fault and im not even going to adjudicate on it, because i consider it to be too dangerous a fault for suposition of what is actually rong with this vehicle ..it shuld be taken back to the dealer immediatlly and not taken on a public road until this serious problem is professionally repaired..s

#10 jeff_leopard

jeff_leopard

    Newbie

  • Members
  • 7 posts
  • 0 thanks

Posted 02 October 2010 - 09:25 AM

I had this problem on my Mondeo (2.0L TDCI 2004) - it would drive fine, then cut out with no warning. It would always restart without any problems. I changed the cam sensor with no change, and took it back to the dealer.

He changed the IMV and the car has been perfect every since!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users