Jump to content





News Feed (View All Updates)


Photo

immobiliser problems


  • Please log in to reply
15 replies to this topic

#1 njp01

njp01

    Member

  • Members
  • 10 posts
  • 0 thanks
  • Vehicle Driven:mk3 mondeo v6
  • Name:neil
  • Location:England

Posted 20 November 2011 - 12:32 AM

The immobiliser on my mondeo keeps malfunctioning,L.E.D on clock keeps flashing when ignition swiched on, had a new key cut and re-programmed at ford dealership. this has not solved the problem. help.......
Mk3 mondeo v6

#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,602 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 20 November 2011 - 03:12 PM

Check the ring around the steering column lock.


Is it a rapid flash or a slow flash?

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


Thanked by 1 Member:
njp01

#3 njp01

njp01

    Member

  • Members
  • 10 posts
  • 0 thanks
  • Vehicle Driven:mk3 mondeo v6
  • Name:neil
  • Location:England

Posted 20 November 2011 - 10:41 PM

Have tried replacing the black ring sensor with a 2nd hand one, and have tried to re-programme the keys,this has not solved the problem,have also tried re-programming the keys manualy to the immobiliser system as it says in the owners manual this also has not worked, The L.E.D flashes rapidly when key is in position 3.
Mk3 mondeo v6

#4 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,602 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 21 November 2011 - 12:59 AM

How many keys do you have?


Where abouts are you?

Try removing the cowl and test the keys by moving the sensor rins closer to the keys.


Would help if you said what you have done and did anything make a difference.

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


Thanked by 1 Member:
njp01

#5 njp01

njp01

    Member

  • Members
  • 10 posts
  • 0 thanks
  • Vehicle Driven:mk3 mondeo v6
  • Name:neil
  • Location:England

Posted 23 November 2011 - 07:06 PM

I now have two keys, originaly only had one, but got another cut and re-programmed as i thought this would solve the problem.

I live in skelmersdale, lancashire , I have had the car for over 18 months and nothing like this has happened before.

I have tried various things to sort it out I.E. dis-connecting battery, changing the ring sensor (for 2nd hand one, off a 51 plate) , re-installing the keys. non of this has worked so yesterday I sent the car to Fords for a diagnostics test, hoping for a cast iron reason as to why this is happening, they called back today only to tell me that there is no fault (after two tests) and the car is starting fine, they say they will keep it tomorrow and test it again to see if it faults but i fear that when I start using the car the problem will raise its ugly head again
Mk3 mondeo v6

#6 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,602 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 23 November 2011 - 08:05 PM

Re-Installing the keys? How?


Not sure which bit controls the immobiliser?

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


Thanked by 1 Member:
njp01

#7 njp01

njp01

    Member

  • Members
  • 10 posts
  • 0 thanks
  • Vehicle Driven:mk3 mondeo v6
  • Name:neil
  • Location:England

Posted 23 November 2011 - 10:46 PM

Re-Installing the keys? How? ...By following the instructions in the owners manual



Not sure which bit controls the immobiliser?


Mk3 mondeo v6

#8 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,602 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 24 November 2011 - 12:20 AM

You only had 1 key so couldnt add or remove new/old keys. When you got the 2nd key you only had 2 keys. So still nothing
you could do to add or remove keys.

Still puzzled as to how you installed the keys???


Programmed the remote locking maybe? That wont affect the immobiliser.

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


Thanked by 1 Member:
njp01

#9 njp01

njp01

    Member

  • Members
  • 10 posts
  • 0 thanks
  • Vehicle Driven:mk3 mondeo v6
  • Name:neil
  • Location:England

Posted 24 November 2011 - 09:44 PM

You only had 1 key so couldnt add or remove new/old keys. When you got the 2nd key you only had 2 keys. So still nothing
you could do to add or remove keys.

Still puzzled as to how you installed the keys???


Programmed the remote locking maybe? That wont affect the immobiliser.






Spoke to ford garage today, diagnostic flagged up a problem in the wireing between the ignition and the p,c,m / e,c,u . They think maybe moisture has got into the wireing, the problem now being that to test the wiring the loom will have to be unplugged from the p,c,m / e,c,u and if the needle-like connectors break through corrosion, the pcm/ecu will need replacing at a cost of £800+ , with a large labour cost on top of that................... Think I might go cry myself to sleep now!
Mk3 mondeo v6

#10 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,602 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 24 November 2011 - 09:49 PM

Or buy a 2nd hand ecu for about £60 ?

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


Thanked by 1 Member:
njp01



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users