Jump to content





News Feed (View All Updates)


Photo

Limp mode issues flashing Coil light


  • Please log in to reply
51 replies to this topic

#1 Cadairmanuk

Cadairmanuk

    Advanced Member

  • Members
  • 31 posts
  • 0 thanks
  • Vehicle Driven:Mondeo
  • Name:ben
  • Location:Gwynedd

Posted 13 April 2012 - 08:35 PM

Hello every one.

I have a problem with my 2002 mondeo tdci 130bhp. Today it went into limp mode with the coil light flashing on the dash board. I have just bought a code reader so waiting on that but in the mean time is there anything I can try to rectify the problem? The car has done 85k with full history been in the family for 4 years with no issues. Its just had a full service last week. The engine revs freely on tick over , no smoke and starts ok and the car has been running really well up to this point. Tonight I disconnected the battery and left for 30 mins but the light was still flashing even before the car was started. What's my next move?

Ben

#2 Cadairmanuk

Cadairmanuk

    Advanced Member

  • Members
  • 31 posts
  • 0 thanks
  • Vehicle Driven:Mondeo
  • Name:ben
  • Location:Gwynedd

Posted 14 April 2012 - 08:23 AM

I have just tried starting it no joy and smoking like a chimney blue smoke. Any initial ideas?

Ben

#3 bojcistv

bojcistv

    Not so Little Megger anymore

  • Members
  • 397 posts
  • 26 thanks
  • Vehicle Driven:Mondeo TDCI
  • Location:Bosnia and Herzegovina

Posted 14 April 2012 - 08:39 AM

It is very hard to say any thing without reading the error code. There could be few issues but lets wait for the error code. On the first i might say it is about injector(s) or fuel pump but there can be another causes.
Something is wrong with my Ford today but I don't know what it is

Mondeo Mk3 2.0 TDCi 130 HP

#4 Cadairmanuk

Cadairmanuk

    Advanced Member

  • Members
  • 31 posts
  • 0 thanks
  • Vehicle Driven:Mondeo
  • Name:ben
  • Location:Gwynedd

Posted 14 April 2012 - 08:48 AM

Ok then I'll sit tight I have another car so it can site and wait.. I will be back with my fault codes. The car was running and sounded mint even in limp mode ,would it be running rough if it was injectors? Egr valve possibilities? I guess from looking on the forums it could be a host of things

Thanks

Ben

#5 salta

salta

    MEG Corporal

  • Members
  • 5,531 posts
  • 368 thanks

Posted 14 April 2012 - 07:27 PM

HI Ben . the first thing that springs to mind is .the motor has just been serviced. this may point to something that was done in the service that did not go well with the engine . so the most common cause for this may be fitting a wrong fuel filter . . if a bosch .delphi or motorcraft .ie ford filter is not used then fuelling problems can arise from using spurious makes of filter .. soo . check the fuel filter is one of these makes then also check if the fuel filter is actually filling up with fuel and to do this simply take off the return pipes an look down int ot the bigger opening you shule see fuel . if you dont then try refilling the filter manually though the inlet to the filter , right up to the brim.. then check all the three connections on top of the filter for tighness and for being clipped home properly . .. as for clearing the fault code light this you can do when you get f super .. some flashiing code light dont clear by simply disconnecting the battery for half and hour some have cleared then by disconnecting over night . but radio codes will be lost so make sure you havve you r radio code if you do this . s

#6 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,592 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 15 April 2012 - 12:56 AM

What code reader did you purchase? Cheap handheld readers wont work on early cars.

You need something like the F-Super off ebay for £24 ish. But it needs a laptop (USB port and software)

Cheapest handheld unit that will work is about £150.


Without a fault code or live data your chasing your tail looking for the fault. Unless you stumble across it
by accident.

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


#7 Cadairmanuk

Cadairmanuk

    Advanced Member

  • Members
  • 31 posts
  • 0 thanks
  • Vehicle Driven:Mondeo
  • Name:ben
  • Location:Gwynedd

Posted 15 April 2012 - 05:13 PM

I bought this http://www.ebay.co.u...#ht_2204wt_1185 hope it gives me the info I need. Car wont start at all trying to fire but wont start up. Hopefully the lead should be here tomorrow or tuesday.

Ben

#8 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,592 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 15 April 2012 - 08:52 PM

Sorry but that reader wont work on your 2002 car. ELM works on diesels from 2004 onwards.

You need an F-Super.

This....

http://www.ebay.co.u...=item1c25c95e88

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


Thanked by 1 Member:
Cadairmanuk

#9 Cadairmanuk

Cadairmanuk

    Advanced Member

  • Members
  • 31 posts
  • 0 thanks
  • Vehicle Driven:Mondeo
  • Name:ben
  • Location:Gwynedd

Posted 15 April 2012 - 09:04 PM

Ah man you joking? I will have to send it back then and get the other. Doesn't say anything about the years which is annoying. You would think they would clearly state 2004 onwards or words like that!! Ok thanks for the heads up , looks like a few more days wait :smoking:

Ben

#10 PURPLE_2L_LX

PURPLE_2L_LX

    Mondeo Mk3 Moderator

  • Mondeo Mk3 Moderator
  • 16,592 posts
  • 776 thanks
  • Vehicle Driven:Estate, TDCI 130 (6)
  • Location:westmidlands

Posted 16 April 2012 - 12:48 AM

Yeah bit of a crap listing, If you check other ELM interfaces they usually say diesels from 2004 onwards.

The F-Super will work on a 2002 car, MIne works on my sisters. Cant read or code the injectors though.

But does read/clear codes and shows live data.

2004 TDCi 130 LX Estate. (6)


MK3 FUSE INFO CLICK HERE ......... FORD WIKI CLICK HERE ........... FORD ETIS CLICK HERE


Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).


Thanked by 1 Member:
Cadairmanuk



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users