Jump to content





News Feed (View All Updates)


Photo

Air bag light flashing 4 times


  • Please log in to reply
21 replies to this topic

#1 v6sierra

v6sierra

    Likes to chat

  • Members
  • 67 posts
  • 0 thanks
  • Vehicle Driven:Xr4i
  • Name:Geoff
  • Location:England

Posted 28 April 2012 - 07:00 PM

Ok here goes, having bought the car the airbag light was flashing away I have looked on here and found the informative mirez site.
However after checking the wires under the seat the little annoying light is still there flashing away at me.
What else would be causing this problem, do I need to replace something????

#2 siruncle

siruncle

    missing the "view new content" button

  • Mondeo Mk1&2 Moderator
  • 16,526 posts
  • 1007 thanks
  • Vehicle Driven:mondeo 2.0 ghia mk2
  • Name:Pete
  • Location:Rutland

Posted 28 April 2012 - 10:41 PM

the light flashing 4x is for the seatbelt pre-tensioners and that's all, so its the seat bits that are the problem, you undid the yellow connectors under both front seats and plugged them back in a few times each, (can take a few times undoing, doing up to clear the fault) i presume?

the only other things it could be is a faulty pre-tensioner, (or its been fired), or the wiring between seat and airbag module.
From Rutland, Leicestershire or Northamptonshire? Join the Rutland Group, http://www.talkford....land-area-page/ Leicestershire, http://www.talkford....leicestershire/ or Northamptonshire, http://www.talkford....rthamptonshire/
2000 (W) Mondeo Mk2 Ghia 2.0 Hatch in Stardust Silver, now needing a pair of front jacking point covers... msg me

Ever noticed that putting "anal" in front of some ford model names makes them sound funny? Fiesta, Probe, Ranger. Explorer, Maverick etc... lol

Thanked by 1 Member:
Exeter Mondeo Man

#3 v6sierra

v6sierra

    Likes to chat

  • Members
  • 67 posts
  • 0 thanks
  • Vehicle Driven:Xr4i
  • Name:Geoff
  • Location:England

Posted 29 April 2012 - 07:30 AM

Thanks, will try and have a look again today if this rain goes away, looks like I may have to get a couple of known to be good pre tensioners so I can eliminate them.

#4 EvoUK

EvoUK

    Big Buttie Megger

  • Members
  • 899 posts
  • 19 thanks
  • Vehicle Driven:2000 Mondeo ST24
  • Name:Neil
  • Location:gloucestershire

Posted 01 May 2012 - 07:12 PM

You'll probably find as siruncle has posted by unplugging and plugging the connectors that will solves the problem. Maybe a bit of electrical contact cleaner spray would help too. Sometimes just moving the seat forward/backward, hoovering the carpets can jolt it enough to loose a full connection thus the flashing airbag light.


Mondeo ST24 Medium Steel Blue

#5 Funkydunks Mk2

Funkydunks Mk2

    Likes to chat

  • Members
  • 71 posts
  • 0 thanks
  • Vehicle Driven:98 MK2 Mondeo verona
  • Location:hampshire

Posted 04 May 2012 - 05:40 AM

Got the same problem. Looks like a dry day finally, so I'll give that a go this afternoon. Funny though mine only started flashing after i "tested" the handling on one of Basingstokes many roundabouts.
1998 Mondeo Verona. 1.8i Zetec silver top. Built: Feb 2nd 1998. 144000k. Probably needs an engine overhaul.

#6 Funkydunks Mk2

Funkydunks Mk2

    Likes to chat

  • Members
  • 71 posts
  • 0 thanks
  • Vehicle Driven:98 MK2 Mondeo verona
  • Location:hampshire

Posted 04 May 2012 - 05:42 AM

Got the same problem. Looks like a dry day finally, so I'll give that a go this afternoon. Funny though mine only started flashing after i "tested" the handling on one of Basingstokes many roundabouts.
1998 Mondeo Verona. 1.8i Zetec silver top. Built: Feb 2nd 1998. 144000k. Probably needs an engine overhaul.

#7 B1ggsy

B1ggsy

    Likes to chat

  • Members
  • 330 posts
  • 10 thanks
  • Vehicle Driven:Mondeo MK3
  • Name:Biggsy
  • Location:England

Posted 04 May 2012 - 06:55 AM

My Mk2 also does this, it is a common fault and i was told by my mechanic it is a sensor issue. He reset it several times each time lasting a few days to a few weeks. Dunno what the long term solution is, maybe replace the sensor or disconnect it?



#8 siruncle

siruncle

    missing the "view new content" button

  • Mondeo Mk1&2 Moderator
  • 16,526 posts
  • 1007 thanks
  • Vehicle Driven:mondeo 2.0 ghia mk2
  • Name:Pete
  • Location:Rutland

Posted 04 May 2012 - 05:54 PM

i chopped the plugs off and joined them up "permanently" with choccy blocks Like these, (well, same as): http://www.ebay.co.u...#ht_1192wt_1139
From Rutland, Leicestershire or Northamptonshire? Join the Rutland Group, http://www.talkford....land-area-page/ Leicestershire, http://www.talkford....leicestershire/ or Northamptonshire, http://www.talkford....rthamptonshire/
2000 (W) Mondeo Mk2 Ghia 2.0 Hatch in Stardust Silver, now needing a pair of front jacking point covers... msg me

Ever noticed that putting "anal" in front of some ford model names makes them sound funny? Fiesta, Probe, Ranger. Explorer, Maverick etc... lol

#9 Funkydunks Mk2

Funkydunks Mk2

    Likes to chat

  • Members
  • 71 posts
  • 0 thanks
  • Vehicle Driven:98 MK2 Mondeo verona
  • Location:hampshire

Posted 05 May 2012 - 07:38 AM

Sounds like my sort of fix. Lol. Although if im going to make it permanent, I'll probably solder them together. My seat belt neefs renewing really. It struggles to reel back in. Would that cause a pre-tensioner warning? Would it be best to remove the seat when i solder them? The rails needs lubing anyway as its very stiff. Thanks. :-)
1998 Mondeo Verona. 1.8i Zetec silver top. Built: Feb 2nd 1998. 144000k. Probably needs an engine overhaul.

#10 siruncle

siruncle

    missing the "view new content" button

  • Mondeo Mk1&2 Moderator
  • 16,526 posts
  • 1007 thanks
  • Vehicle Driven:mondeo 2.0 ghia mk2
  • Name:Pete
  • Location:Rutland

Posted 05 May 2012 - 11:14 PM

Sounds like my sort of fix. Lol. Although if im going to make it permanent, I'll probably solder them together. My seat belt neefs renewing really. It struggles to reel back in. Would that cause a pre-tensioner warning? Would it be best to remove the seat when i solder them? The rails needs lubing anyway as its very stiff. Thanks. :-)


you could remove them for better access to solder them and protect the carpet, and grease the rails whilst its out, DON'T move the forwards/backwards lever once the seat is loose as they are a :BEEP: to re-align. Pre-tensioner only works on the clip bit of the seat where the belt plugs into, what it does is pops a spring so the clip bit moves, yanking you back in the seat in a head on collision, all the wire does is check the circuit to fire it is working, if the connection is duff or the pre-tensioners fired, that'll make the light flash. Try pulling the belt out and using aerosol furniture polish (like pledge) iirc, on the bit you don't wrap round you (both sides) and a little down the hole where it goes, it might take a few days to work but should help it retract. :L
From Rutland, Leicestershire or Northamptonshire? Join the Rutland Group, http://www.talkford....land-area-page/ Leicestershire, http://www.talkford....leicestershire/ or Northamptonshire, http://www.talkford....rthamptonshire/
2000 (W) Mondeo Mk2 Ghia 2.0 Hatch in Stardust Silver, now needing a pair of front jacking point covers... msg me

Ever noticed that putting "anal" in front of some ford model names makes them sound funny? Fiesta, Probe, Ranger. Explorer, Maverick etc... lol




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users