Jump to content





News Feed (View All Updates)


Photo

Error codes - p2291 / p0251


  • Please log in to reply
22 replies to this topic

#1 dreaddan

dreaddan

    Big Megger

  • Members
  • 460 posts
  • 2 thanks

Posted 17 March 2011 - 09:31 AM

I've got my code reader today and have read the DTC's that point to the Inlet Metering Valve that needs replacing,
So can any one tell me where it is/how to replace it as I cant find it in haynes so I can check the contacts.
Also I think I read that it needs to be coded to the ECU is that right?

The codes were
p2291 injector control pressure too low - engine cranking
p0251 injector pump fual metering control a

Cheers
Dan
02 Mondeo TDCI Ghia x in Panther Black.

#2 totalguy

totalguy

    TDDI Buff

  • Members
  • 37,014 posts
  • 388 thanks
  • Vehicle Driven:mondeo tddi
  • Location:Rhondda Cynon Taff

Posted 17 March 2011 - 10:22 AM

when was the fuel filter last done how many miles ago?
51 plate ghia x tddi with extra oomph

Boost Pressure = ((MAP x 10) - BARO)/6.895 (use with F-Super readings)

My Blog http://abitoveverything.blogspot.co.uk

#3 dreaddan

dreaddan

    Big Megger

  • Members
  • 460 posts
  • 2 thanks

Posted 17 March 2011 - 11:20 AM

It was last done on tursday(a week ago) so about 400 miles. I requested a bosh one to be put on during the service it had.
02 Mondeo TDCI Ghia x in Panther Black.

#4 fibo666

fibo666

    Newbie

  • Members
  • 100 posts
  • 4 thanks
  • Vehicle Driven:Mondeo
  • Location:lincolnshire

Posted 17 March 2011 - 02:33 PM

The imv is on the end of the pump under the inlet manifold. It has a brown electrical connection and should be next to the fuel temp sensor which is blue. That's if its a tdci 130. Hope that helps

#5 bar2433

bar2433

    Little Megger

  • Members
  • 22 posts
  • 0 thanks
  • Vehicle Driven:mondeo mk3 tdci
  • Name:Brian
  • Location:eastyorkshire

Posted 17 March 2011 - 08:22 PM

I've got my code reader today and have read the DTC's that point to the Inlet Metering Valve that needs replacing,
So can any one tell me where it is/how to replace it as I cant find it in haynes so I can check the contacts.
Also I think I read that it needs to be coded to the ECU is that right?

The codes were
p2291 injector control pressure too low - engine cranking
p0251 injector pump fual metering control a

Cheers
Dan

Just changed mine and it made no difference £120 wasted. P0251 can be lots of things P2291 comes on after the engine has been started a certain number of times with P0251 present.
Its usually pump or injectors causing it.

#6 dreaddan

dreaddan

    Big Megger

  • Members
  • 460 posts
  • 2 thanks

Posted 18 March 2011 - 11:23 AM

Im going to try to make it do it again while I have the lappie and cable in the car this weekend so hopefully I'll get more info before i replace anything.
but given i get abit of blue smoke at start up I feel it might be a injector.
02 Mondeo TDCI Ghia x in Panther Black.

#7 totalguy

totalguy

    TDDI Buff

  • Members
  • 37,014 posts
  • 388 thanks
  • Vehicle Driven:mondeo tddi
  • Location:Rhondda Cynon Taff

Posted 18 March 2011 - 02:39 PM

It was last done on tursday(a week ago) so about 400 miles. I requested a bosh one to be put on during the service it had.


has it happened since it was changed or before? it could be a faulty filter even if it is bosch
51 plate ghia x tddi with extra oomph

Boost Pressure = ((MAP x 10) - BARO)/6.895 (use with F-Super readings)

My Blog http://abitoveverything.blogspot.co.uk

#8 dreaddan

dreaddan

    Big Megger

  • Members
  • 460 posts
  • 2 thanks

Posted 18 March 2011 - 03:10 PM

Both.
It happend a few times before and once again since
02 Mondeo TDCI Ghia x in Panther Black.

#9 totalguy

totalguy

    TDDI Buff

  • Members
  • 37,014 posts
  • 388 thanks
  • Vehicle Driven:mondeo tddi
  • Location:Rhondda Cynon Taff

Posted 18 March 2011 - 07:57 PM

its probably not the filter then.

seems an odd one to me i thought the fuel filter may have sorted it. how is the car actually running though? is it ok, smoking etc?
51 plate ghia x tddi with extra oomph

Boost Pressure = ((MAP x 10) - BARO)/6.895 (use with F-Super readings)

My Blog http://abitoveverything.blogspot.co.uk

#10 bar2433

bar2433

    Little Megger

  • Members
  • 22 posts
  • 0 thanks
  • Vehicle Driven:mondeo mk3 tdci
  • Name:Brian
  • Location:eastyorkshire

Posted 18 March 2011 - 09:43 PM

Im going to try to make it do it again while I have the lappie and cable in the car this weekend so hopefully I'll get more info before i replace anything.
but given i get abit of blue smoke at start up I feel it might be a injector.

Have tried that and it just showed the same codes.
Had a leak back test done today and one injector is leaking back considerably more than the others especially at higher revs which would cause a drop in pressure in the rail. Hopefully i have found my problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users