Jump to content





News Feed (View All Updates)


Photo

DAB Radio problem


  • Please log in to reply
4 replies to this topic

#1 rac6

rac6

    Just Joined TF!

  • Members
  • 1 posts
  • 0 thanks
  • Vehicle Driven:New C-Max 1.6 Tdci
  • Name:Nick Rac
  • Location:England

Posted 13 June 2011 - 11:18 AM

I have a NewC-Max 1.6 TDCi Titanium (11) plate. The DAB radio suddenly stopped working. The AM/FM works fine but no DAB. After three visits to the dealer a new rear screen was fitted as the bonded wire had become detatched, which picks up the signal. This didn't fix the problem and the dealer is stating that the vehicle is so new that they are even at a loss as to why it does not work? Has anyone else had this issue?

#2 4titx

4titx

    Over Enthusiastic

  • Gold Member
  • 5,374 posts
  • 206 thanks
  • Vehicle Driven:Mondeo 4 Titx
  • Name:Phil
  • Location:westyorkshire

Posted 13 June 2011 - 12:40 PM

Well I'd suspect the radio itself if its so new, unless the radio is fed with a separate antennae cable for DAB and its dropped out.
LEDs, whats your Watts.
2.0 TDCi TitX in Hypnotic Silver

Dont thank me, thank him. I'm just the messenger.

#3 Mark_War

Mark_War

    Just Joined TF!

  • Members
  • 4 posts
  • 0 thanks
  • Vehicle Driven:C-Max 2.0 TDCi '11
  • Name:Mark
  • Location:England

Posted 27 July 2011 - 06:20 PM

Hi rac6,
I don't know if this is any good for you but I also have the new C-Max 2.0 TDCi Titanium (11) plate.
I lost my DAB around 4 weeks ago, I took the car into the dealer and they check all the connections which meant taking the dashboard off, they could not find anything wrong with it, so the dealer ordered a new radio.

Over the weekend the DAB came back. Ford are aware of this problem but do not know what is causing it.
Its also affecting the new Kuga and Mondeoas well as the new C-Max's.
Tell your dealer you want the radio replaced there should not be a problem as the car is so new. The DAB aerial is the wire you can see wrapped around the aerial under the plastic coating.

Hope this has helped.

Mark

#4 Chris Hall

Chris Hall

    Just Joined TF!

  • Members
  • 1 posts
  • 0 thanks
  • Vehicle Driven:Ford C Max 1.6 tdci
  • Name:Chris Hall
  • Location:England

Posted 12 August 2011 - 10:10 PM

ohh great - my DAB radion died today and I was hoping that this was something simple!! I've got a 11 plate grand c max and is only a couple of months old. Already had one mfctr recall, still waiting for a repair to the middle off side seat fabric trim and now the DAB has got up and gone....brilliant (not) I like DAB radio and it's frustrating me that its died, will have to call them tomorrow and sort out a booking. If i find anything new, will post re this.

#5 apcauson

apcauson

    Just Joined TF!

  • Members
  • 1 posts
  • 0 thanks
  • Vehicle Driven:S-Max
  • Name:Anthony Causon
  • Location:England

Posted 11 January 2012 - 01:27 PM

This is interesting to hear about other people having DAB radio issues, I drive a 2011 SMax and find that about 30 seconds after starting the engine and driving off the radio repeats itself, its so weird, however this also happens with FM as well. It also does it when the signal is weak, was going to wait until it goes in for a service to get it looked at, but judging by what has been said here that may not be very successful.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users