Ford Automobiles Forum banner
acceleration
1-14 of 14 Results
  1. Diesel Engines (Mk4 Mondeo)
    Hello TF family, I feel my car doesnt accelerate properly, it is sluggish in low revs, refuses to pick up quickly, sluggish until 2000 rpm once turbo kicks it, torque doesnt seem great. I know the engine is small and car is heavy but this is ridiculous as at round abouts its a case of im going...
  2. Diesel Engines (Mondeo Mk3)
    I have a 2 litre diesel Mondeo Titanium (2006). This problem has only happened twice in the last 3 weeks btw. I was driving it normally, not flooring it etc, when the engine light came on and the throttle stopped working. The engine continued to idle so I was able to park up, switched the engine...
  3. Diesel Engines (Mondeo Mk3)
    Some help please. I own a 53 plate 130 (6) engine with about 73K on the clock. Recently the car has developed a noticeable judder at higher speeds (I would say 55/60mph +) which feels like the car being buffeted by a strong headwind. This isn't apparent at lower speeds. This is accompanied by a...
  4. Diesel Engines (Mondeo Mk3)
    Hi, Few days ago I noticed that when I'm driving steadily in any gear, for example in third around 40kmh, if I depress throttle pedal wehicle accelerates by itself to around 50 and it stays there. I'ts the same with the fourth gear, it goes to 60-62kmh and just keeps it there until I press...
  5. Mechanical (Focus Mk3)
    I been here a few times before to find out information on faults for friends, but now I actually own a Ford I suppose it was just a matter of time before I needed help myself I currently have a Focus 1.6 zetec tdci 61 plate mk3. It's done 50k miles and I generally do any work on cars myself...
  6. Ford Fiesta Mk4 / Mk5 Forum - (1995-2002)
    Hi all, Im new to the forum and new to fords! just bought a fiesta 1.3 2000 which was driving absolutely fine and has been for 3 months but as of yesterday it has started to 'kangaroo' under heavy acceleration... start up and idle is absolutely fine, if im gentle on the accelerator it drives...
  7. Mechanical (Focus Mk1)
    Hi all, just replaced the two short banded pipes leading into my inter cooler, took car out and when I accelerate past 2000rpm in all gears the revs will jump to about 4500rpm with slow acceleration. It eventually speeds up and is normal again. Looks like oil is spraying out of the grill from...
  8. General Car Talk
    Hi I am new to Talkford and would like some advice. I have a Ford Mondeo ZETEC 1.6 Y reg car. I have noticed the last few weeks than when I am in 1st or 2nd gear and turn at junctions or roundabouts there seems to be a lack of power at accelerating and sometimes to go down to 1st gear to get...
  9. Mechanical (Mk2 Focus)
    Hi all. Just driven a circa 150 run and noticed that when the engine is under load, be it steep hill or hard acceleration, the heater stops blowing hot and the temp gauge moves down half the gauge. No cream under the oil cap when I set off - ill check again when the engines cooled down. Is it...
  10. Diesel Engines (Mondeo Mk3)
    Hi folks. I pulled into a layby to let an ambulance past the other day, and in my panicked state, nearly stalled it and kind of half missed a gear. Straight away afterwards I got a VERY loud grinding noise on acceleration. I thought I'd knackered by gearbox at first but then it eased a little...
  11. Diesel Engines (Mondeo Mk3)
    Hello, could anyone tell me if there's anything you could accidentally do to a diesel engine that would seriously decrease the power? Since I left my 01 Mondeo diesel in for repairs a while back it seems like a different car - no acceleration, needs to drop to third gear to go up a hill it...
  12. Mechanical (Mk2 Focus)
    Upon Hard Acceleration, Air pushes rapidly through the dashboard air vents. Only seeming to happen when the turbo kicks in. Could this possibly be a leaking / disconnected vaccum hose or connection ?
  13. Mechanical (Focus Mk1)
    New here so please be nice. I don't know alot about engines so here goes... Bought my Focus 1.8 TDDi in November 2011. I changed the font set of tyres as they went bald on the inside. This was in April. The same problem has happened now. That's problem 1 - not important really. 6 weeks ago, I...
  14. Diesel Engines (Mondeo Mk3)
    Hi folks. First post in these forums, and of course I'm asking for advice. The car: 2004 Mondeo Zetec TDCi 130 2.0l diesel. I've had the problems in the past where the glow plug light comes on, and the acceleration power vanishes in the car - but it rarely happens now; say once every 2 or 3...
1-14 of 14 Results
Top