Ford Automobiles Forum banner
coil
1-5 of 5 Results
  1. Ford C-Max Forum
    Hi folks, a real head scratcher ... CMax 1.6 Ltr Petrol 2005 Car was cutting out in traffic, diagnostics had 2 errors - P2300 and P2303 ignition coil circuit problems. The car has been with three different mechanics (inc. Ford mechanic), no definitive answer to the issue. What was done: -...
  2. Electrical (Mk3 Mondeo)
    Hi guys, I have an odd problem that I can't quite get to the bottom off. Therefore turning to the great and good on the forum. I have put this in "Electrical" because my gut feeling it is an electrical problem, but not 100%. Car: Mondeo Mk3, '04 plated, Ghia X Saloon, 2.0l Petrol...
  3. 1.8L / 2.0L Duratec Petrol Engines (Mondeo Mk3)
    Hi All I am new to this forum and not sure how to present my problem. but i will give it a try - I have a 2004 ford mondeo petrol 1.8 - 66k miles on the clock. It was all good before I got my car serviced. Infact it was ok for few days after the service hence I am not 100% sure the servicing...
  4. Suspension/Wheels/Brakes/Steering (Mk3 Mondeo)
    Hey everyone, after changing the front end suspension on my missus 04 Ghia (new springs, top mounts, ARB links), it failed MOT on a broken REAR spring!! Looks pretty simple in the Haynes book, I've had a wheel off and had a look, doesn't look like there's any surprises. Would appreciate any...
  5. Electrical (Mk3 Mondeo)
    Hi, I'm at the end of my tether here. After a long drive a few weeks ago, my engine started to run roughly and ultimately when I stopped the car, it wouldn't start again. Thinking the coil pack was the problem, I but a new one on and it ran very briefly before stopping and not turning over...
1-5 of 5 Results
Top