Ford Automobiles Forum banner
display
1-5 of 5 Results
  1. Ford Fiesta Mk6 & Fusion (UK) Forum - (2002-2008)
    my ford fiesta display has went blank and no imoblizer light flashing ,not turning over when turned to start position and tacho is reading 1000 rpm all the time .... lock the car off the fob and unlock no flash of the indicators ....checked all fuses all ok and double checked earths under bonnet...
  2. General Car Talk
    Hi there, I own 2 Fords: a 2010 Focus SW Titanium LED and a 2009 S-MAX Titanium. On both of them the displays (dash and Sony's head unit) stay on several minutes after turning off everything. In fact, if you open one of the front doors, they light up and remain lit for, I don't know, maybe 20...
  3. Electrical (Focus Mk3)
    Hope I'm not starting a topic that has already been discused. Is there any way that the vehicle speed in MPH can be displayed within the computer display? I've been through the menu but can't find anything. Looks like I will have to rely on the speedometer. Thanks in anticipation
  4. Electrical (Mk3 Mondeo)
    I have used this forum for this problem before, but I thought another crack at bending your minds again. to start with I have a Mk3 prefacelift '03 Mondeo, 2.0 TDCi, Ghia, automatic...(in black!) My problem is that when I turn the ignition on I get a full digital display on the instrument...
  5. In-Car Entertainment (Mk4 Mondeo)
    I have a 3 month old Mk4 estate and when I started the car today I noticed the display on the 6000CD radio was blank. Some of the buttons appear not to work but the radio and BT still work. I am a little surprised that this would happen of such a new unit. How I perform a full reset of the...
1-5 of 5 Results
Top