Ford Automobiles Forum banner
heating
1-13 of 13 Results
  1. Ford Fiesta Mk7 Forum - (2008-2017)
    Hello all ! Im hoping someone can help with a problem i'm having with my 2012 Fiesta titanium econetic! Intermittently the heater and the cruise control refuse to work! The heater refuses to work whatever buttons I push - the small temperature display is blank - and cruise control also...
  2. Diesel Engines (Mk4 Mondeo)
    Hi there again, I am here to obtain as many answers to my problems, so if it is possible, i hope for responses asap :) My mondeo MK4 2.0 tdci Ghia 103 kw 6-gear sedan is starting roughly in lower temperatures. When it's over 20degrees celcium it starts with no problems in one to two turns...
  3. Air-Con / Heating (Mk3 Mondeo)
    I have a 53 2004 Mondeo and today of all days the heating ceased to work either through the ac mode or eco mode, all I was getting was tepid / barely lukewarm air on either mode. I've seen a few posts but wondered if there was a set order on what to investigate first and take it from there. The...
  4. Air-Con / Heating (Mk3 Mondeo)
    Hi can some one please shine some light on the problem with the misses mondeo please..... The heaters always blowing cold, controls dont work. tried 2 units and dont make any difference on it Only way to stop them from blowing is remove the fuse in the engine bay Cheers
  5. Air-Con / Heating (Mk3 Mondeo)
    Hi All, First post here so i do apologise if this has been covered 40,000 times before. I have a Mondeo MK3 TDCI (130) and in the last few weeks i've noticed a few issues with the heating systems. Issue 1: Heater not blowing on window, this morning in the icy weather i noticed that when i hit...
  6. Electrical (Focus Mk3)
    Hey there! Been lurking for a while, thought it was time I joined up :) My Focus (2011+/mk3) is poorly :( The `outside temperature` is reading a permanent 25 degrees c Inside, I've got climate control/air conditioning, but if it's on at all, no matter what temperature I set, only one...
  7. Ford Streetka and Sportka Forum
    Hello, I have some issues with my Street Ka 2005 brought from new). About a couple of months ago when I went to close the door using my keyfob the alarm staring going after 8 mintues, I'd checked that all doors were shut and they were and as I didn't now what was wrong I didn't lock my car for...
  8. Air-Con / Heating (Mk4 Mondeo)
    My 1.8 tdci never seems to manage to hit 90 degrees. It is always 75/80 but sits there solid ass a rock with no fluctuation! Any idea if it should be hitting 90? Many thanks
  9. Air-Con / Heating (Mk3 Mondeo)
    For those who are searching the forum and hoping to find answers to similar problems, I hope this helps you. Since I bought the car, the heater direction has been stuck on windscreen. I had the control panel checked, and that turned out to be fine. From what I can see now, I've removed three...
  10. Air-Con / Heating (Mk3 Mondeo)
    I wonder if anyone can help me on this one. I have a Mondeo 2.0 petrol Ghia '52. For a while now the heating takes a while to kick in (about 5 miles/10 minutes) and comes on rapidly, if the engine revs are greater than approximately 2,000rpm. However, when the engine is idling no heat comes...
  11. Electrical (Ka Mk1)
    Hi all, I hope you can help! I drive a 2002 Ford Ka, and let's just say it's showing it's age! This summer the heater went and constantly blew hot air despite dial position, I changed the Heater Control Valve and the problem was fixed. But now I suspect that the internal control panel isn't...
  12. Diesel Engines (Mondeo Mk3)
    I would be very grateful if someone could point me in the right direction before i spend too much on trial and error. I currently own a Mondeo Mk3 2ltr TDCI Duratec 2005 "55". Since owning it i have noticed that in the colder days the engine takes some time (4 to 5) miles to get up to temp. I...
  13. Mechanical (Focus Mk1)
    Hi i'm new and ive got a ford focus mk1 T reg diesel and for some reason the temp gauge stays on the middle when starting the car its cold and then after 5-10 mins of driving it racks up halfway and i'm not sure what it could be. The coolant is level and new, air filter was installed in march...
1-13 of 13 Results
Top