Ford Automobiles Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. Electrical (Mk4 Mondeo)
    Hi, 2013 Mondeo 2.0 Estate. Have seen various threads on issues with the wipers, but cannot find anything the same as the issue I'm currently having. Drove to work yesterday morning - no issues until it gets to lunchtime... Try to wash the windscreens and whilst the fluid is sprayed across...
  2. Ford Fiesta Mk7 Forum - (2008-2017)
    Hello, I have a Fiesta mk7 (mk7.5 in Brazil). It there are 4 doors, in the past, before changing the battery, when any of the 4 doors are opened, I lock using remote key and sounded two horn beep. So now two horn beep just when some of the 2 front doors is open. Is there any programming to...
  3. Electrical (Mk1/Mk2 Mondeo)
    ST200 Estate Spiral connector Finis code 1090887 (from the Ford invoice) For ages I had a flashing airbag light, 4 flashes then a gap etc. Then I realised also the horn was not working. Long story short (after following various threads in here) took it to Ford and they traced it to a common...
  4. Ford Ka Mk1 Forum (1996-2008)
    Hi, today I took my car in for a free health check with Ford. They turned around and said to me that my horn is inoperable, which I laughed at because I've used it so many times before, however when I got home I pressed it and it didn't work, about 10 minutes later I tried again and it worked...
  5. Ford Fiesta Mk4 / Mk5 Forum - (1995-2002)
    Hi all, I'm hoping someone could offer me some advice... I'll try to tell this story as concisely as possible - my old car recently failed it's MOT. It's a 1998 Fiesta Mk4, 1.3 Endura, and worked out not to be economical to repair. I got a 2000 Fiesta Mk5 Finesse 1.3 to replace it, which was...
  6. Ford Cougar Forums
    Hi everyone, im totally new here but I really need help so here goes! I own a 1.6 cougar and the other day I hit the kerb, only slightly but since then my horn hasnt been working. Im hoping a fuse has blown or something simple but ive got a nagging feeling I have done some proper damage and a...
  7. Security / Safety (Mk3 Mondeo)
    First fault on my mk3 face mondy today in the 8years since new. The horn seems to have stopped working. As a test, I double locked the car and opened the bonnet, which would have sounded the alarm (expected horn, flashing lights etc.) - but nothing happened so I guess it's connected. Any ideas...
  8. Electrical (Mk1/Mk2 Mondeo)
    Hi, Just been reading on here and elsewhere about the airbag lights, ours has been flashing once every 5 seconds so after looking at codes on Mirez I assume the drivers airbag is the fault. The Horn suddenly stopped working a couple of days ago too, and I have tried the cruise control today...
1-8 of 8 Results
Top