Ford Automobiles Forum banner
no power
1-8 of 8 Results
  1. Diesel Engines (Mk4 Mondeo)
    I have a 2010 titanium x tdci 2.0L mondeo, duratorq engine, 163bhp. Engine malfunction light was intermittent a few months back (Jan/Feb), it seemed to be constantly on recently until I sprayed in some normfest dc980 air intake cleaner, it runs fine and accelerates, no smoke, no hissing (like a...
  2. Diesel Engines (Mk4 Mondeo)
    Hi All. I have a 2010 Mondeo 1.8 tdci zetec that is really trying my patience. About eight months ago it started to cut out when it came to parking outside the house after driving. It's getting progressively worse as it now does it when moving off onto a roundabout, parking at the shops and...
  3. Ford Transit / Tourneo / Connect Forum
    Hi, My banana engine recently had timing changed, it had the engine locked on all the correct holes, even the big hole on the fly wheel. After around a week the engine lost all power driving up hill to the point where i was high revving in 2nd gear and pumping out black smoke. At the same time...
  4. Diesel Engines (Mk4 Mondeo)
    Hi Guys. I have just purchased a Ford Mondeo MK4 Estate 1800c Diesel 2009 plate 80k miles on the clock Body interior and under the bonnet looks new. I don't have any mechanical knowledge. Ok from cold she performs perfectly loads of power and drives smoothly. When the temp goes up after about...
  5. Ford Transit / Tourneo / Connect Forum
    Hello I would appreciate any advice as to what maybe wrong with my van. The orange coil light came in the dashboard, van lost power then completely stopped. It will not start at all now. It is a 51 plate 2002. I had two seperate diagnostic tests done by two different mechanics, one came back...
  6. V6 'Duratec' Petrol Engines (Mondeo Mk3)
    Hi guys once again I'm having issues with my 2002 2.5 V6 Zetec S MK3 mondeo. Was on my way to friends and noticed the car was a little low on power. Not too much but it was noticeable the usual kick from the V6 was missing. Car was running low on fuel so I thought this was most likely the...
  7. Mechanical (Focus Mk1)
    Have a ford focus zetec 04. Running rough as if on 3 cylinders all the time right through rev range. idles badly, trouble starting. Diagnosis tests prooved all sensors ok changed head gasket and checked valves which all looked ok plugs leads and coilpack all changed. cylinder one doesnt seem to...
  8. Ford Fiesta Mk6 & Fusion (UK) Forum - (2002-2008)
    Subtitle: Oh god another 1.4tdci with no power!! Hi my names Linda and I am the proud owner of an 06 tdci which has never run right. I believe there are two separate faults 1. Car cuts out whilst Maneuvering 2. Total lack of power when driving The second is much more of a problem than the...
1-8 of 8 Results
Top