Ford Automobiles Forum banner
power loss
1-13 of 13 Results
  1. Diesel Engines (Mk4 Mondeo)
    Hi all, I've had my mk4 for 2.5 years and no problems with it until now. Its a 2012 2.0TDCI 140bhp. Intermittently in the last few weeks when I have been accelerating the engine was not responding properly, more noticable when pulling out onto a main road trying to get up to speed or when...
  2. Mechanical (Mk2 Focus)
    HI all ... I have recently purchased a Focus Titanium 2010 1600 TDCI with 82k ...I was not sure at first as I used to have a 2lt mondeoTDCI but I seem to be losing power it has happened 4 times in 5 weeks ..they car seems to not want to respond, there is very little pull even by dropping down...
  3. 1.8L / 2.0L Duratec Petrol Engines (Mondeo Mk3)
    Hey I was hoping someone could help me out with my problem. I've got a 53 plate Mondeo Petrol. When I first bought the car second hand, engine light came on and was telling me it was running lean. Took it to Ford and they've change the upstream O2 sensor which was quite expensive. I drove it...
  4. Diesel Engines (Mondeo Mk3)
    Hi all. I recently bought a cheap run about to fire me up and down the motorway to work, a mondeo 130 2.0 03 diesel hatchback. 125k I need it to be fairly reliable so carried out, - brakes all round, - new cam sensor (grey one to replace black one). - new dual mass fly wheel and clutch (was...
  5. Electrical (Mk4 Mondeo)
    The story If anybody is having traction control/abs issues with the front left wheel speed sensor and abs wiring, where the lights are coming on intermittently I have just found out the hard way that the engine wiring loom can suffer breaks behind the passenger side headlight(back of wheel...
  6. Diesel Engines (Mondeo Mk3)
    Good afternoon Guys, I have studied this forum and I must say it's fantastic!! I have a 2007 Mondeo Zetec s Tdci 130, its has been bomb proof, best car I have owned, its a real work horse and has covered 185,000 miles. However!! All of a sudden I noticed that when attempting to charge up a...
  7. Diesel Engines (Mondeo Mk3)
    HI all, My 2001 Mondeo has developed another fault. The vehicle smokes when under load or acceleration over 2krpm. Vehicle hits motorway speeds fine, starts without fault and has no engine management lights on or fault codes stored?. I changed one of the injectors a few months back and all...
  8. Diesel Engines (Mondeo Mk3)
    Hi all, new member here I own a 54plate Mondeo tdci 115. Recently the car has developed a problem whilst accelerating from about 2000rpm . The engine will suddenly lose power and the glow plug light will flash. If i kill the engine for a few seconds and restart the flashing light has gone and...
  9. Ford C-Max Forum
    Anyone help me with a puzzling problem. On longer journeys I have an occasional but recurring problem where usually at a roundabout I pull away and the turbo refuses to cut in and I am then stuck without the turbo and max revs of c.2500 for remainder of journey. A short stop seems to rectify...
  10. Mechanical (Mk2 Focus)
    Problem No Power, no kick, no oomph, no turbo Some 'chugging' or juddering when the kick should have cut in Preceding Circumstances No issues driving for for the past several months Midway through a long drive I stopped at Shell to fill up Driving out of the garage there was a noticeable loss...
  11. Diesel Engines (Mondeo Mk3)
    Hello, could anyone tell me if there's anything you could accidentally do to a diesel engine that would seriously decrease the power? Since I left my 01 Mondeo diesel in for repairs a while back it seems like a different car - no acceleration, needs to drop to third gear to go up a hill it...
  12. V6 'Duratec' Petrol Engines (Mondeo Mk3)
    Hi all, got my zetec s in april and am really enjoying it, however... recently had a new clutch and slave cylinder fitted by ford and since then i've had a few problems. The car seems to ride the clutch of its own accord, after changing up or down a gear it initially changes smoothly but then...
  13. Diesel Engines (Mondeo Mk3)
    Hi all, 55reg 110,000 miles TDCI similar problem to some other posts here. Last week noticed i had an intermitttent loss of power when accelerating aboot 2000rpm. Thought it could be EGR related and was going to have it off (oooh vicar) on sunday for a good clean and function check. This...
1-13 of 13 Results
Top