Ford Automobiles Forum banner
rough idle

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. Diesel Engines (Mondeo Mk3)
    my mondeo idles rough, it drives great but it just wont idle smooth so i decided to use the f super tool to see if there was anything injector related that comes up. first i got 1 DTC which is a P0405. ill have to check over the vacuum lines and make sure the vacuum pump is working. ive already...
  2. Diesel Engines (Mk4 Mondeo)
    Hi All, I have the following issue with my mondeo that really bothers me. I noticed the rough idle a while ago ( few months) but think it's getting worse. What was done so far: about the car: Mondeo 2010 ( before facelift). 2.0 tdci, 140 hp, 200.000 km Complete driving belt (kit?) was...
  3. 1.8L / 2.0L Duratec Petrol Engines (Mondeo Mk3)
    Re-posted with tags - hope that's OK. Hi all, hope you can help! I have a 2004 Mk 3 2.0 Petrol CJBA on 112000 miles. Big end went whilst in Spain, so I (eventually) got a replacement crank, shells etc. Upon re-starting, 2 valves dropped, knackering the head. I (eventually) got a replacement...
  4. Ford Transit / Tourneo / Connect Forum
    Hello, I've a petrol Connect from 2005 it uses the 1.8 Zetec SE / Sigma / Duratec 115hp engine; it developed a CEL with Misfire#1. Since then I have replaced: - Coil pack - plugs - wires - MAFit - fuel filter After this it was still throwing the code so the ECU was checked and the company...
  5. Diesel Engines (Mondeo Mk3)
    Folks looking for some inspiration: I own a 55 plate 2.2TDCI Titanium X. 105,000 on the clock and everything has been great until recently. She starts first time, regardless of weather/temp etc BUT runs really rough and can (but not always) produce grey smoke on initial start up. If I run the...
  6. Mechanical (Focus Mk1)
    Hi guys, I Have a 2003 Focus TDCI 1.8 Sport, Recently its been having starting problems, like taking 10 seconds to start. No loss of power unless in 5th gear at 50 if you put your foot to the floor it goes into limp mode (Flashing Glow Plug Lights) Ignition off and on again on the move and its...
1-6 of 6 Results
Top