Ford Automobiles Forum banner
speedometer
1-9 of 10 Results
  1. Ford Galaxy Forum
    Hi, not sure if anyone has the answer to my problem as i have looked at many posts and cant find one that matches my problem! i have a 2006 mk3 Galaxy 1.8 tdci , 6 spd 130k that recently had a failed alternator. i drove the car home just on the battery, as i was getting closer to home i noticed...
  2. Ford Transit / Tourneo / Connect Forum
    I have a 2003 mk 6 transit which im converting into a campervan and this requires some additions to the electrics. Today after not properly screwing a part in, sparks flew and the immobiliser kicked in, after sorting this out I drove the van but the speedometer is now not working. Ive tried the...
  3. Ford Streetka and Sportka Forum
    My SportKa (07) had been sounding slow to turn over in the morning then yesterday I just had the solenoid clicking when I turned the key. I put the battery on charge (started OK), left it off charge in the night, and it was weak again by morning, so a replacement battery seemed worth a try. I...
  4. Interior & Exterior (Mk1/Mk2 Mondeo)
    So, yesterday my mondeo 1997 mk2 generator broke, couldn't start blah blah blah... got to service replaced it of course with good second hand spare(new is expensive) and now maybe it's in my mind but my headlights are brighter and interior HUD also is brighter but few bulbs are dead so i want to...
  5. Electrical (Mk3 Mondeo)
    Hi, I am new here and completely non tech so I hope someone can offer me a bit of advice please. I have a MkIII 2007 Mondeo Diesel Ghia. I was driving along at about 50 mph and I suddenly noticed my speedo zoom round past 100 mph and keep going until it stopped at zero but the wrong side of...
  6. 1.8L / 2.0L Duratec Petrol Engines (Mondeo Mk3)
    Had a problem with my speedo showing 0 on the revs and speedo, along with some random lights (engine management / alternator light / Frost temp light) I was thinking that it could be a faulty speed sensor not sending information to the ECU, but my Ford dealer was quite sure that this model...
  7. Electrical (Mk1/Mk2 Mondeo)
    Hi, anyone got any tips for refitting a speedometer gauge on a mk1 mondeo, took it out today along with the instrument cluster binacle, tried to put it back in and the speedometer gauge will only go back so far then won't budge, don't want to force it as it could break the end of the speedo cable.
  8. Ford Transit / Tourneo / Connect Forum
    Hi, I have a 2004 Mk6 100ps t350 swb transit. I was driving my van today and the rev counter and speedo stoped working, left it for a few hours when i started it again. the rev counter and speedometer gauge were still not working. started and stopped it a few times but still not working. so when...
  9. Ford Fiesta Mk4 / Mk5 Forum - (1995-2002)
    Hi guys, I have had a new car battery fitted by RAC and when using my car an hour and a half after they left i went to drive my car and my speedometer and rev counter dials are not moving and have completely gone in a full circle so my speedometer dial is on 160 mph and the rev counter has gone...
1-9 of 10 Results
Top