Ford Automobiles Forum banner
trip computer
1-5 of 5 Results
  1. Electrical (Mk1/Mk2 Mondeo)
    Hi, I just thought that I would add this in case someone has the same problem as me and couldn't find the simple solution on the forums (maybe I was hopeless at using the 'search' facility). My 1997 Mondeo Mk2 2.0i Ghia X's trip computer started losing it's information (time, date, mpg...
  2. Electrical (Mk4 Mondeo)
    Right so I've read most of the posts on this page that I think relate to my fault but to no avail. I was wondering if there was any updates to the following faults? Its a 2.0 TDCi (140) 2009 Parking Sensors: When selecting reverse you get a long single beep and a flashing parking sensor button...
  3. Fuels / Oils / Additives / MPG
    Recently bought a ulta low mileage 1.6 TDCI and discovered I got a trip computer with it (prev. had an LX) but the MPG seem to be showing v.low - just 50 MPG on an extra urban journey and quickly dropping to around 45 mixed use! Just the trip computer, or should I be looking at anything else...
  4. Electrical (Mk2 Focus)
    Can anyone tell me why my mpg and avg speed keep resetting themselves in my mk2 focus ghia tdci, is there a battery i need to change or a fuse maybe? all the gauges drop down to nothing then go back up when i start the car. HELP please its really annoying.
  5. Electrical (Mk2 Focus)
    Hi guys, I have recently installed a new Pioneer 2-Din head unit and sub and noticed last night when i got home that when I turn the car off and lock it the trip computer is staying illuminated! I waitied for around an hour and it didnt go out, when i checked this morning it was still on too...
1-5 of 5 Results
Top