Ford Automobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hi, i have just brought a 2014 titanium x 1 ecoboost
The car is in great condition full f.history and had pre sale service. the dealer said he was an ex ford dealer and was working with them for 5yrs and new all about them.

When the car was started the radiator fan came on straight away, i asked the dealer about it and he said it was normal because it was 30 degrees + and the car was in a barn which was really warm inside so I took his word for it and carried on with the purchase as it drove well and there is no obvious issues.

But the fan is still coming on at the turn of the key even when the engine is cold. I'm seeing conflicting things on forums with some saying its normal due to how the engine was designed and not to worry and some saying it could be thermostat or a relay. have tried with different combos air con off etc and still no change.

would love to hear from other ecoboost owners to help put my mind at ease.

thanks !
 

·
dont listen to me, you'll have horsepower and
Joined
·
3,439 Posts
The fan comes on with the aircon so is the AC turned on?
 

·
Clever Clauggs
Joined
·
4,613 Posts
Just tried mine the fan doesn't come on ,i would say its a faulty coolant sensor saying engine is hot,coolant sensor from £10. My Fiesta 1.0 ecoboost titanium 2014 30kmiles is serviced by me last 3yrs,exhaust is starting to blow
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Just tried with the blowers turned off as well as the air con and it hasn't come on.

Does yours come on with just the blowers on with air con off?
 

·
Clever Clauggs
Joined
·
4,613 Posts
Tried with blower and air con on, only for a short while, but fan did not come on, after a run fan is on goes off a short while after switching off engine.Will try tomorrow as dont want to annoy neighbours..
 

·
Clever Clauggs
Joined
·
4,613 Posts
Tried it at 19c outside temp cold engine,blower on full A/C off, fan is on and after restarting fan is still on with fan and A/C off, if your fan doesn't switch off at all it might be the coolant sensor.

Mates 2016 Fiesta ecoboost temperature gauge is stuck at one bar cold so coolant sensor is not working, another car peugeot coolant sensor was stuck on hot running fan continuously till battery died.
 

·
MEG Corporal
Joined
·
2,801 Posts
  • Like
Reactions: mondy zetecs

·
Clever Clauggs
Joined
·
4,613 Posts
Turned engine on temp 23c no fan, A/C and blower on fan starts,restart engine fan still on.

Thanks Frembit will take closer look.
 
1 - 10 of 10 Posts
Top