Ford Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
Hi guys,

Quick question for anyone who might be able to help.

I've got a 2011 Ford Mondeo Facelift and i activated Hill Launch Assist in Forscan. It shows up in the settings menu, and i have no errors in forscan or on the dash (ABS etc works fine) but HLA doesn't work even when set to Auto in the settings. I'm wondering whether i need to restart the ABS module for it to work, or do i need someone with the proper ford software to activate it? (Not sure i do, as when i did my ACC retrofit on my old mondeo, it was all done in Forscan and ELMconfig).

If there was any issues with actually activating it, i'm sure i'd have got a a few DTC's in forscan and an ABS/ESP error within the car it's self and it wouldn't have worked at all?

Not sure what to do here, so any help would be great!
 

·
Registered
Joined
·
319 Posts
You have to have a compatible ABS unit as it contains the sensor for tilt. If it’s an auto then it should come supplied as standard. It was an option on manuals as I recall. 👍
 

·
Registered
Joined
·
1,634 Posts
Yes, as above. You need the specific ABS unit for it to work.

If it wasn't enabled at factory, it's probably unlikely to work if you change the vehicle configuration without changing out the ABS module.
 

·
Registered
Joined
·
319 Posts
An ABS module swap isn’t a trivial activity as it’s coded into the rest of the system and can only be done with dealer level equipment 😕
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #5 ·
I was under the impression that all Facelift Mondeos are born with HLA but don't have it activated unless bought, as the ABS module on the facelift contains the module and the yaw sensor in one?

I know when i did the ACC retrofit on my old Mk4, i had to swap out the ABS/Yaw sensor, as mine wasn't compatable. Also, if it wasn't compatable, wouldn't i have the brake config mismatch error on my car and some DTC codes? It's pretty strange, but hey, it's not a deal breaker, i just wanted to see if i could get it working haha. I'm not doing a full ACC retrofit on this Mondeo as the parts are really hard to find and from what i can see, it doesn't have any of the wiring already there :(
 

·
Registered
Joined
·
1,634 Posts
No, there were 4 different ABS units depending on the car configuration for the facelift.

Controllers for FL: 1754797, 1857634, 1857635 and 1857636
Modulators for FL: 1792180, 1857637, 18576388 and 1857639
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #7 ·
No, there were 4 different ABS units depending on the car configuration for the facelift.

Controllers for FL: 1754797, 1857634, 1857635 and 1857636
Modulators for FL: 1792180, 1857637, 18576388 and 1857639
Aaaaah that explains it then!

I still find it odd how it shows up in the settings, and theres no errors or anything caused, but it doesn't work. Not the end of the world though to be fair! I'm not swapping the ABS module out though, that really is a difficult job!
 

·
Registered
Joined
·
1,634 Posts
The module is basically the same, just without the sensor, so it won't give an errors - it just never gives the signal that the vehicle is on a hill.
 
1 - 8 of 8 Posts
Top