Ford Automobiles Forum banner
1 - 20 of 43 Posts

·
rasa
Joined
·
148 Posts
Discussion Starter · #1 ·
abs kicking in,no dashboard lights,have been told it is the abs ring,is this correct ,and how much are the to buy and replace,also will i damage the car more if i drive it the way it is,could i disconnect the abs,if so where and how,
 

·
Super Moderator
Joined
·
31,063 Posts
Does the ABS light work when you switch the ignition on?

ABS faults will be a part of the MOT soon, No warning light or a light that doesnt flash the correct sequence will be an
MOT failure.

Dont have an odd tyre a cheapo nogripsky,lingylongy etc brand?
 

·
Super Moderator
Joined
·
19,005 Posts

·
TDDI Buff
Joined
·
37,060 Posts
the car will work with abs light on just no abs so the wheels can lock up. fine to drive like that ive done so.

it would be good to get the codes read to check which one it is unless youve done so?

why are you told its the ring? its usually a sensor connection or the sensor. ring can only go 2 ways, dirty or cracked.
 

·
rasa
Joined
·
148 Posts
Discussion Starter · #7 ·
mate owns his own garage,and he says that is what it is,do these cars have a ring to replace or do u have to replace the cv joint or wheel bearing.i ask this as i cannot seem to source a ring for a mk3 ,only a mk1 or mk2,but have seen cv joints with ring attached for mk3,can only get to his garage next week to read the codes,assuming he can read them,his code reader should be able to as it cost him £2300,any help on subject would be helpful as im interested in all mechanics of cars even though i am a novice,
 

·
Super Moderator
Joined
·
19,005 Posts
i think the earlier mondy3's had abs rings on the cv joint, then went to bearing mounted "ring". The latter also now gives a signal to the speedo, doing away with the vss on the gearbox (vss-vehicle speed sensor)
 

·
Super Moderator
Joined
·
19,005 Posts
without looking, its hard to tell you, mate, presumably you've seen the ring on the cv joints, these are usually behind the front discs, with a sensor mounted towards the back, you should be able to feel the steps in it if it has rings on cv's.
 

·
TDDI Buff
Joined
·
37,060 Posts
i got early mk3 both ive owned had ring 2001 maybe they did it on driveshaft on earlier ones. ive had a y plate and a 51 plate now so maybe it was the x reg ones. never heard of it though

the ring comes on the bearing not seperately and it will be ring on bearing for 2003 for sure
 

·
Registered
Joined
·
46 Posts
1) Did anyone find a fix for this ABS problem as I have the exact same thing happening to me but like somone said, I cannot find any ABS rings for the MK3, only MK1 and 2?

2) When i started my MK3 DTCI up tonight and went to set off and after a few yards the glow plug light came on and went into limp mode as if it were running on 2 cylinders with loads of light blue smoke belching out the back. I reversed back and turned the engine off and then restarted it and seemed normal and ran it for about an hour without a problem?

Any ideas would be welcome..
 

·
Registered
Joined
·
5,525 Posts
There should be a code logged if the gp light came on. This should give a clue. An f_super or good elm327 cable (both < £15) plus relevant software (free) will read codes and display some useful live data.

Also handy for checking if you have any abs codes logged, and I think forscan (software used with an elm327 cable) can probably display abs sensor outputs.

Check for poor sensor connections, cagged up sensors, different sized tyres (it happens!).
 

·
Clever Clauggs
Joined
·
4,579 Posts
Tidon if you take the wheel off and look behind the hub, where driveshaft goes

into the bearing,with torch,there should be a dark magnetic ring on the bearing,

also at the top a black abs sensor can be seen just infront of the ring.

Make sure the ring is clean,

If you don't have this you will have the earlier type.
 

·
Registered
Joined
·
46 Posts
Cheers guys for the Diagnostic tools as I will be checking them out of if anyone can post me a link it would be welcomed and also cheers for the pic but in the mean time while I get someone to sort it could I take the ABS fuse out to disable the ABS and would the brakes still work as its pretty scary when the ABS starts ti kick in and the brakes begin to fail..

Cheers
 

·
Registered
Joined
·
46 Posts
Only the bearing if needed http://www.ebay.co.uk/itm/181694746970?_trksid=p2055119.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT

Try a new sensor first and make sure magnetic ring on the bearing is clean.

The bearing needs to be pressed in but i used a bearing kit to press it.
Cheers for the reply but apparently the sensor seems ok as the ABS light does not stay on as it goes out when the car is started and its just the classic ABS fault that a lot of people have with the ABS kicking in when braking? Does the magnetic ring come with the bearing or do you buy the ring separately as It doesn't show the magnetic ring on the bearing and in the pic above the magnetic ring doesn't look like its attached to the bearing and looks separate?
 

·
Clever Clauggs
Joined
·
4,579 Posts
The magnetic ring is on one side and comes complete with the bearing like this

http://www.ebay.co.uk/itm/Jaguar-X-Type-Inc-Saloon-Ford-Mondeo-MK3-Cougar-EC-Orbis-Front-Wheel-Bearing-/291053073356?hash=item43c41d73cc:g:M-YAAOSwA3dYfnQ3

I have just done mine,abs light was on found the ring was full of muck,fitted

a new bearing no abs light on but it was making scraping noise as i braked ,found

the abs ring had metal filings from me doing ball joint so cleaned off and

everything works as it should.

 
1 - 20 of 43 Posts
Top