Ford Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter · #1 ·
I need to replace my advance solenoid.

Typical symptoms are,
- Blue smoke at idle and lower rev range
- Rough idle (shaking car and lacking power when pulling away)
- poor mpg
- poor proformance

I think i have located the advance solenoid, as there isnt many pictures of where it is located. (The MK2 is front mounted.) The MK1 seems to be fitted to the rear of the pump, facing the block and glowplugs.

There is a wire going to a connector and 1 connected to the pump base as a earth i guess.

As anyone replaced this, can it be done in situ or does the pump need to be removed?

I will remove the other pipes etc to aid access but dont want to remove the pump.

Also what size spanner is the socket?

I have included a pic of the advance solenoid where i think it is, to help other MK1 TD owners.

Jordie
 

Attachments

·
Registered
Joined
·
2 Posts
I have been looking into this too, recently.

A mechanic told me a few days ago that Mk1 mondeos don't have advance solenoids, only Mk2 onwards...

I don't know a lot about what's under the bonnet so you might want to check this with someone else before you take my word for it
 

·
My name is Steve
Joined
·
6,700 Posts
IIRC, mine was a small Valve unit, just had it replaced :confused:
Problems were none starting, ie spring was shutting off fuel and thus air getting in etc.
was on the end of the pump, right hand side
 

·
Registered
Joined
·
210 Posts
Discussion Starter · #5 ·
jameshebble said:
I have been looking into this too, recently.

A mechanic told me a few days ago that Mk1 mondeos don't have advance solenoids, only Mk2 onwards...

I don't know a lot about what's under the bonnet so you might want to check this with someone else before you take my word for it
Just been told this by a mechanic today.
 
1 - 5 of 5 Posts
Top