Ford Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
Many thanks to MR T (Rick) for plugging in his fault code reader last night while i was collecting some bits.

The upside was it confirmed i have a faulty VSS... so thats on the list for a change.

the downside was it also came up with this code:
P0320 - Ignition/Distributor Engine Speed Input Circuit Malfunction.

Anyone have any ideas as to what this might be?

Im thinking cam/crank sensor but assumed that they would have their own Fault codes..... :whistling:

any suggestions?

Cheers
 

·
Big Megger
Joined
·
293 Posts
well the code's explaination mentions engine speed input curcuit so maybe this code is a consequence of the first as they both seem to be relating to roughly the same thing? i.e speed or engine speed??

just a thought
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #3 ·
well after doing some digging around..

fault could be with the CPS... or the associated wiring... or the plug into the ECU.. or my thought is a problem with the Superchip perhaps??

will have to fit the other parts i have got and go from there! lol
 

·
Yo
Joined
·
3,632 Posts
Just had a quick look on google, a lot of sites make mention of the PIP signal, which is something to do with the crank sensor. I would take a look at the wiring down there, and see if there is any obvious damage, and maybe take it off and clean / replace it. People who have that fault code also report a missfire over 3000 rpm, so perhaps it is something to do with the knocking noise you are hearing at those revs, i.e. the injector / ignition timing is off and so causing the noise.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #5 ·
good point...

the car will rev above that point and on the way back it was pulling along the motorway at 3.5k+ with no problems.. just doesnt have the get up and go without the secondaries (but soon to be fixed! ;) )

the wiring and associated sensor are next on the list of things to check! when its gets a little lighter! lol
 

·
Yo
Joined
·
3,632 Posts
Talking of secondaries - you will never guess what just gave out on mine on the way home today!!! Oh well, such is life :}
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #7 ·
no way! :surprised:

dont know what to say mate... :sad:

if i check mine nad ifnd that its related to the crank sensor and the secondaires are infact working fine then i will give you first refusal back! lol
 

·
Yo
Joined
·
3,632 Posts
Nah don't worry about it, I will either get my bro to fix mine or buy a new one. Just weird timing thats all :}
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top