Ford Automobiles Forum banner
1 - 6 of 6 Posts

· Little Megger
Joined
·
4,941 Posts
The mk3 self levelling shocks are stupidly expensive! My Ghia X is fitted with them too and the bellows are also breaking up. If you find a solution, please post it here!
 
  • Like
Reactions: riber3

· Little Megger
Joined
·
4,941 Posts
  • Like
Reactions: riber3

· Little Megger
Joined
·
4,941 Posts
I can't see how you can pull 'em off as the end has got the fixing eye attached.
 
  • Like
Reactions: riber3

· Little Megger
Joined
·
4,941 Posts
Thing is those shocks were only fitted to Ghia Xs, so not many on here will have seen gaitors on their rear shocks. So.not a lot of experience of such things... you are literally trail blazing here!
Do you have a link to those Topran ones?
 
  • Like
Reactions: riber3

· Little Megger
Joined
·
4,941 Posts
Have you seen those youtube video demonstrations of superglue mixed with bicarb or even better, with graphite. Seems to make a pretty damn strong bond.
 
  • Like
Reactions: riber3

· Little Megger
Joined
·
4,941 Posts
Long story!.... I'll try to shorten it. I was getting running probs due to a tired pump. Managed to get a refurbed pump £100, fitted it and was getting gr8 fuel pressure, but was emptying the fuel filter, and was not drawing enough on the low pressure side to fill it. . I worked on it through Nov, Dec and Jan 2020-21 in freezing cold getting nowhere, so decided to put old pump back, caught a cold, wasn't thinking clearly and screwed up causing timing chain sprocket to slip. This meant having to remove timing chain cover, retiming engine, etc.... I lost my mojo as was right out of comfort zone by now. Fast fwd to October 2022, I needed to move Mondy out of carport in order to work on my daughter's car. So by now got a bit of confidence restored, so managed to put it together (with old pump) and got it running. Still haven't put aux belt and alternator on. I've since read from someone on the Jag X-Type forum, that some fuel filters come with the water tap on the bottom not fully screwed tight and THIS was the cause of my new pump not having enough 'suck' to draw fuel from the tank. (as I had fitted a new filter at the same time as pump change) will still need to refit the new pump to test this theory, but am awaiting warmer weather now! Thanks for asking, btw!
 
1 - 6 of 6 Posts
Top