Ford Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Hi guys,

Am I weird or something? I've had this problem with my 2.0 duratec MK3 mondy running a bit 'rough' at times .. during a couple of months I've tried to figure out when it was running rough, vibrating more and making more noise and when it would run smooth as silk .. I checked just about all hoses, sensors and stuff .. Got religous about the weather pondering, making systems in regards to air temp, moisture and other stuff related to when it ran well and when it didn't...

THEN I went to the yearly maintenance, they changed oil, fixed the break, poured a couple of oz of coolant (Was a bit low) on the engine.. Guess what ... It now runs smooooth as silk, cant hear the engine, cold or warm, moist or not, accellerating or not, 80mph og 10mph ... It just seem SO much more comfortable...

The question is, could it really be that a simple oilchange did this much? It's like getting a luxury car after having driving a truck .. Dont get me wrong, it would drive like this every now and then before but not very often ... Another thing, when i bought it, it had been in the dealers warehouse for about 5 month without moving ... Bought in april 2006.

Final thing, I've refurbished the aux belt tensioner, only worked for about a month and then the 'grasshopper' sound reappeared, suppose I need to spend the £100 on a new tensioner....
 

·
MEG Corporal
Joined
·
801 Posts
have checked the oil level and how many miles/km you've done during this period?
if oil level was low or the oil was too thin it starts vibrating.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Nah I never did check the oil level - Was busy checking sensors and hoses so I completely forgot about that one ... I guess I assumed that if the oil level was low, a red light would be lit on the dashboard ....

It's really weird, it now drives better than any car I've ever had, no noise from the engine, silent as a whisper on the motorway everytime I drive the car, not just once in a while .. Only negative thing is that now I notice the tyre and wind noise :laugh: Guess you can't have it all but it's very relaxing to drive now.
 

·
MEG Corporal
Joined
·
801 Posts
one man to be happy with his motor here!
that is sensational!
usually we are all patients around.
 

·
Registered
Joined
·
4 Posts
Sounds like mine might need the same treatment! Had my 02 2.0 Ghia for just over a month now and think that it sounds quite rough. Have regularly checked the oil and this has been okay but the car (like yours) had been on a forecourt for a while.

Did/does yours have a particularly rough spot around 3000 - 3500 rpm? This makes for particularly noisy cruising :sad:

Have a great Christmas and any help appreciated :L
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top