Ford Automobiles Forum banner
21 - 24 of 24 Posts

·
Little Megger
Joined
·
46 Posts
Discussion Starter · #21 ·
Thanks Tred. Your detailed explain give me great confidence to do this job by myself. Actually I did think about to replace the pipe in a lunch time like you did. However, I remind myself I am a novice. It may take more time for me to do the job. :) So I decided to do it during weekend. I will post my progress once I have done it.
 

·
Little Megger
Joined
·
46 Posts
Discussion Starter · #22 ·
Finally I changed my pipe this weekend. Thanks for everyone who helped me here. :thankyousign: The procedure is exactly like Tred's explaination. I just want to point out thing. The nut of jubilee clip at the bottom of my car need a 6mm spanner to do the job. However, the smallest one in my tool box is 7mm. So I have to put everything back and drive to a motor factory to buy a 6mm spanner. So make sure you get a 6mm spanner before you start this job. :)
 

·
Little Megger
Joined
·
27 Posts
I want to say a big big THANK YOU :L :L to everyone who has posted on this thread and on other threads on the same issue!

I too had the poor mpg, black smoke, lack of power, feeling like someone was applying and releasing the brakes for me at 2000 rpm, etc that many others have reported. I thought my car was dead.

The advice and guidelines on the site gave me the balls and info needed to find a crack on my intercooler to egr boost pipe, get the bugger off and even remove and clean the egr at the same time (did the MAF sensor too).

All the above issues have vanished into clean, black, smoke-free thin air :banana: Took her out for a spin today and I couldn't believe the difference. my mpg has even shot up from a meagre 35 mpg to over 50, and that with having a good play with my new found power!

so thanks all, hope I can be as helpful to others as you have been to me :thankyousign:
 

·
Big Megger
Joined
·
559 Posts
Just come back from Fords I wanted the ecu updating as I know It has not been serviced by fords for a while.Anyway apparently the service guy gave me an advisory that the intercooler pipe was split,So Off I trot to get the pipe and have fitted it (5 min job)but on checking the old one I was damned if I could find a split in it :eyesup: any way put the new one on I also checked the bottom one with the wire round it all ok there.I had a feel around the intercooler pipes (where the vibration fix is) [color:red]and could feel another rubber pipe I couldnt feel any leaks there but has any body had issues with that pipe?[/color]after the update and new pipe I went for a blast up the private track ;) and the smoke on acceleration seems to have gone and so was the 1800-2000 rpm misfire problem but I shall see how it goes over the next few days before I am convinced if it's cured my problems.Fingers crossed.
 
21 - 24 of 24 Posts
Top