Ford Automobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
202 Posts
Discussion Starter · #1 ·
Is there a fuse for the cruise control on a mk2? i can see it in the users manual.

I regularly use the CC and i have just done the brakes on the car as in THIS post which i doubt is linked. but after this the cruise control did not work.

Is there any parts that can go faulty with this system and is there anyway if it isnt a fuse i can check or find the problem?
 

·
Love my cheap to run Mondy's
Joined
·
658 Posts
But he is talking about the brake light SWITCH. That's at the top of the pedal. If that was misadjusted and was touching even slightly, then the cruise would not work. That said, if it was maladjusted, then the brake lights would be on all the time too.

Let us know how you get on, never heard of this before and it would be good to know the cure in case it ever happens to me/us!
 

·
MEG Commander
Joined
·
6,006 Posts
Have you got traction control?
 

·
IDS SERVICES AVAILABLE - DENSO SPECIALIST
Joined
·
3,444 Posts
clock spring is ususally the worst culprit.. Change them over and try again...
 

·
Registered
Joined
·
202 Posts
Discussion Starter · #9 ·
You'll never guess. it the bloody led brake lights i put in that cause the problem as they have they take much less power to operate, the car thinks they are there, and the switches for the cruise control get confused.

so, IF YOU HAVE CRUISE CONTROL, DONT FIT LEDS IN THE BRAKE LIGHTS. (allow you can use load resistors if needed)
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top