Ford Automobiles Forum banner
1 - 20 of 46 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter · #1 ·
Totally Knackered...

Here's the story.

Got front fogs for my Mk2 Diesel 1998. Fitted them and the two pull switch.

All was working fine - side lights, dipped beam, front fogs, main beam.

Them I went to pull switch a second time for the rear fogs to come on - just to check switch was good.

I lost just about everything electrical on the car!

I have:
NO dash lights when turning key - battery and oil etc
NO lights above side lights.
NO rev counter / Speedo
NO heater blower

Probably other stuff not working as well but thought I better get on here and ask questions...

YES to wipers
YES to radio /CD
YES to alarm light on dash
YES to courtesy lights

It would seem that anything ignition controlled is now U/S.

I can start the engine but unsure if in some sort of limp mode as no lights means I can not drive it to check.

What the Hell have I done and how do I fix it?

Like I said I am REALLY desperate here and throw myself to the mercy or other wise of the MEG masters...

Pete
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #3 ·
I did not fit a relay.

I assumed - probably incorrectly - that if wiring was there then relay was fitted.

The front fogs worked fine UNTIL I tried the rear fogs them I lost everything
 

·
MEG Captain
Joined
·
4,819 Posts
right , so you unplug everything you have plugged in , check all the fuses , not sure if the mk 2 has 2 boxes like the mk 3 or not !!!!! , and go from there , i would be surprised if you have done anything really nasty , you just need to check everything out , and to do that you need to go back a few steps :L
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #6 ·
Replaced the two pull switch with original one pull - NO CHANGE.

Checked fuses - can not find one that has blown anywhere - mind you it is a litle dark.

Is there ANYTHING that controls most of the items on the ignition side as that seems to be the problem.
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #7 ·
Guardtower

If I blew a fuse would that also stop all the other stuff from working as in my first post?

I am losing what's left of my hair here - trying to work out what happened.........
 

·
LED Extraordinaire
Joined
·
8,458 Posts
When you have replaced the fuse with a 7.5 amp pull out the light switch housing and look in the hole for a grey 4 pin plug with 1 purple loop of wire, when you find it unplug it and take it into the house and pull the white bit out and change the wire position to pins 3 and 4 :)

This will stop the fuse blowing by routing the power down the correct circuit in the car ;)
 

·
MEG Captain
Joined
·
4,819 Posts
petep900 said:
Guardtower

If I blew a fuse would that also stop all the other stuff from working as in my first post?

I am losing what's left of my hair here - trying to work out what happened.........
popped one fuse in my mk3 and all sorts of lights stopped working !!!!!!!!!!!!!!!!
 

·
MEG Captain
Joined
·
4,819 Posts
guardtower said:
Or may be 34
indecision , indecision :gayfight: :tongue: :tongue: :tongue:
 

·
MEG Captain
Joined
·
4,819 Posts
same here when the fuse popped on mine !!!!!!!!!!!!!!!!!!!! , i thought i had wrecked the car big style !!!!!!!!!!!!!!!!!!!!! :tongue: :tongue: :tongue:
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #18 ·
Been there and done that....
So if I locate the fuse and find the white thingy with the purple wire I should be okay...

...or should I sacrifice a chicken or two for good luck?

I wish I was in Yorkshire now and not Wales as I would be on my way to Hudderfield with a torch shining out of the window! lol!
 

·
MEG Captain
Joined
·
4,819 Posts
like i posted earlier , forget about the front fogs for now and get the car back as it was , then work forward from there :L
 

·
LED Extraordinaire
Joined
·
8,458 Posts
Its a grey plug mate :) if you cant find it then pop in a 10 amp fuse to replace the blown one this will allow a TEMPORY fix to the fuse blows
 
1 - 20 of 46 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top