Ford Automobiles Forum banner
1 - 13 of 13 Posts

·
Garry
Joined
·
27 Posts
Discussion Starter · #1 ·
Argh I think it just lost my last post!

OK I have uploaded a video of my formidable test on the car, but it all looks gibberish to my untrained eyes

Any chance someone could look at it and tell me why my car sounds like an old taxi that's about to explode?

Thank you

Garry

video located at
 

·
Super Moderator
Joined
·
30,056 Posts
Whats the fault code?

Do a leakoff on ther injectors. Change the fuel filter if its not been done in the last 12 months.

Bosch one.. if you can.
 

·
Garry
Joined
·
27 Posts
Discussion Starter · #4 ·
Thanks, just done a complete change of filters air oil and fuel. Not starting now doh, does the fuel filter need anything special like filling first?

Cheers for the help

Garry

Sent from my HTC One using TalkFord.com mobile app
 

·
Super Moderator
Joined
·
30,056 Posts
Yes ALWAYS fill a diesel fuel filter from the inline side only. Or conenct the supply pipe and

suck fuel into the filter.

Probably about 300-400ml of fuel in a filter? Thats a lot of air to remove.
 

·
Garry
Joined
·
27 Posts
Discussion Starter · #6 ·
banner, that will be the reason then. fired up ran then stopped, I take it I will have to also fill the pump now as well.

the battery is charging now so Ill leave it overnight and have another go tomorrow in the light.

one diesel can, 1 gallon of fuel and some strong mints to take away the taste of diesel on the shopping list tonight!

thanks again mate

Garry
 

·
Garry
Joined
·
27 Posts
Discussion Starter · #7 ·
the fault code is for the brakes/cruise. The brakes work well but the cruise isn't working so I reckon that's a different kettle of fish. Did all the numbers add up on the video by the way?

Garry
 

·
Super Moderator
Joined
·
30,056 Posts
Compare your figures to these.. http://www.talkford.com/topic/157208-formidable-and-what-it-should-look-like/

They appear to be about right. Fuel pressure seems OK. Battery voltage OK.

BARO seems slightly low but i have not checked mine at this time of year. Frosty was it?

EGR closes when it should. But it could be leaving gas into the inlet.

Block the EGR and see if that improves matters. Cheap simple fix and easy to remove also.
 

·
Garry
Joined
·
27 Posts
Discussion Starter · #9 ·
Thanks buddy,

The egr is blanked off already, I thought that strange that there it was still showing a reading, I also don't get the engine light on with it fitted which is what I expected.

Cheers Garry

Sent from my HTC One using TalkFord.com mobile app
 

·
Garry
Joined
·
27 Posts
Discussion Starter · #10 ·
Just had a thought, the garage (just before I bought the blooming car in Oct) changed the injectors but when I looked one of them wasn't the right coding on Formidable. I have changed this but working on the basis that the garage didn't programme them properly in the first place it could be that they are in the wrong order.

Working on this picture the top "injector 1" should be on the left hand side while looking from the front of the car? or is it the other way around?

Dude this is much appreciated, really is

Cheers

Garry
 

·
Super Moderator
Joined
·
30,056 Posts
Yes No.1 is the timing chain end not the gearbox side.
 

·
Garry
Joined
·
27 Posts
Discussion Starter · #13 ·
Thanks for all the help, it's still banging away so I'm off to the person that did the injectors to see what he says. It's a good hour and a half away hense the reason I've stalled so far

Garry

Posted Via The Free TalkFord.com App
 
1 - 13 of 13 Posts
Top