Ford Automobiles Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
Front lights malfunction...
2012 Mondeo 1.6titx Xenon's
My problem is perplexing me. i can start and drive the car fine ,after around 20 minutes of driving e, even if the lights are of i will get the bong and the error message ,this will happen about 3 times in succession and then the lights just go to safe position and the yellow dot on converse stays on, until i switch of for 10 minutes ,then it will be ok for a few minutes before it starts again.i have changed the xenons bulbs twice and checked the plugs and wires all seem to be in good condition.

All lights seem to work .I have checked and rechecked the connector blocks all seem in good condition
I have pulled the dtc's from the converse can anybody tell if any of the following are related to the front lights ,and if yes what the problem might be.thanks in advance.
F00616
160782
160787
C14000
C15100
C42268
C40168
C41568
C41668
C42068.
 

·
Super Moderator
Joined
·
29,376 Posts
Assume those are cluster codes? Use a proper OBD tool to read the codes.

Should get better results.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #3 ·
Thanks for quick response i will get the codes read with OBD tool.

Is there anything behind the passenger footwell carpet that can affect the lights , Only ask because tonight had a passenger with long legs in the front and since then the warnings gone for now.
 

·
Registered
Joined
·
162 Posts
Thanks for quick response i will get the codes read with OBD tool.

Is there anything behind the passenger footwell carpet that can affect the lights , Only ask because tonight had a passenger with long legs in the front and since then the warnings gone for now.
A generic OBD scanner will only be of any use for Drivetrain codes and will be of no use in detecting faults with Body electrical, ABS, Airbag systems etc.

If you have an ELM327 try scanning using Forscan
 

·
Registered
Joined
·
1,588 Posts
AFAIK the 1.6 was never fitted with Xenon lights - are they definitely Xenon or are they the adaptive headlights? Which yellow dot?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #6 · (Edited)
Yes they are deffo xeons they go up/down. not left/right when it self levels. i have replaced the bulbs before. I have just put more new 35w osrams in there.
I got myself and elm and forscan came up with this.
OK) [17:48:42.621] Found module: HCM - Headlamp Control Module
(WARN) [17:48:43.626] DTCs in HCM: B1C98:13-68.

There are more DTC but i dont think they related to lighting. Should i be looking for something else in forscan.
Thanks again

Dont know what any of these meen.
(WARN) [17:49:19.196] DTCs in IPC: U3006:16-2B, P1607:82-2A, P1607:87-2A, U0140:00-2A, U0151:00-2A, U0422:68-2A, U0401:68-2A, U0415:68-2A, U0416:68-2A, U0420:68-2A
(WARN) [17:53:20.571] DTCs in PCM: U0120:00-28, P0512:00-6C, P1632:09-28, P0564:00-28, P0564:82-28
(WARN) [17:53:23.806] DTCs in BCMii: C1A59:13-6C, C1D18:00-68, C2003:49-28, B10AC:95-28, B12CD:87-68, B1D00:15-68, U0231:87-2F
(WARN) [17:53:24.153] DTCs in SRM: B1D79:1E-08
(WARN) [17:53:24.633] DTCs in DDM: B1166:11-28, B1166:15-28
(WARN) [17:53:24.888] DTCs in HVAC: U2101:00-28, B105A:14-AC
(WARN) [17:53:25.229] DTCs in ACM: B1A04:13-2F, B1D79:11-28
(WARN) [17:53:25.832] DTCs in IPC: U3006:16-2B, P1607:82-2A, P1607:87-2A, U0140:00-2A, U0151:00-2A, U0422:68-2A, U0401:68-2A, U0415:68-2A, U0416:68-2A, U0420:68-2A
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #7 ·
Just to update.
recalibrated the headlights with forscan 5 hours driving around the town and NO malfunction. So glad i bought the elm could have been a costly fault finding trip to fords.
 

·
Registered
Joined
·
2 Posts
Hi what did you actually find wrong please, mine has headlight malfunction but to me lights are working
Just to update.
recalibrated the headlights with forscan 5 hours driving around the town and NO malfunction. So glad i bought the elm could have been a costly fault finding trip to fords.
Hi what did you actually find wrong please, mine has headlight malfunction but to me lights are working chrisy0:cry:
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #9 ·
chrisy .
after replacing bulbs checking wires and connector blocks for corrosion ,i could not find anything physically wrong.
All i can suggest is connecting to an elm with forscan and perform a callibration of headlights and reset the HCM (headlight control module) this seems to have fixed my problem.

If you are anywhere near FY1 i could do that for you.
 

·
Registered
Joined
·
2 Posts
chrisy .
after replacing bulbs checking wires and connector blocks for corrosion ,i could not find anything physically wrong.
All i can suggest is connecting to an elm with forscan and perform a callibration of headlights and reset the HCM (headlight control module) this seems to have fixed my problem.

If you are anywhere near FY1 i could do that for you.
Hi thank you for your quick reply and kind offer but unfortunately I am up North in Peterlee, County Durham but I will see if my son can do this for me. I will let you know how it goes Christine
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #11 ·
Update. Almost a week and 600 miles later and all still good .No warnings
 
1 - 11 of 11 Posts
Top