Ford Automobiles Forum banner
1 - 6 of 6 Posts

·
I Love Diesel
Joined
·
2,356 Posts
Discussion Starter · #1 · (Edited)
Hi,

Do all Mk3 clusters beep when the frost/ice warning comes on (yellow and red snowflake symbol)? I've just noticed that my ST220 doesn't beep, although the symbols appear. My Tit X always beeped as well - pretty sure it did when you switched the ignition on and it was already at those temps, not just while driving.

Low fuel warning beep does work on the ST220, though, so it can beep!

Thanks.
 

·
Clever Clauggs
Joined
·
4,457 Posts
Just put ignition on its 2c then turned engine on, no bleep,probably only bleeps whilst driving and drops below 5c
 

·
Super Moderator
Joined
·
30,347 Posts
Never noticed at startup but certainly whilst driving and especially noticable when the temperature is borderline,
had it beep over and over as the temperature climbed and dropped above/below zero on the same journey.

Had me wishing for a mute button.
 

·
dont listen to me, you'll have horsepower and
Joined
·
3,336 Posts
Mine always did it on startup.
Sadly her appointment to mondeo heaven is booked for Sunday morning.
Dropped the battery on this morning (it did beep with temp on ignition) and she fired first turn of the engine after about 4 months
 

·
I Love Diesel
Joined
·
2,356 Posts
Discussion Starter · #5 ·
No beep when the frost warning came on while driving home this evening, unless I'm just not noticing it. It's strange as I'm almost certain there is a beep with the low fuel warning. Maybe it's a different beep.
 

·
I Love Diesel
Joined
·
2,356 Posts
Discussion Starter · #6 ·
Definitely no beep with the frost/ice warnings, but there is with the low fuel warning (I get the low fuel warning quite a lot with the ST220).

First World problem, anyway.
 
1 - 6 of 6 Posts
Top