Ford Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a problem with my Ranger Wildtrak 3.2 MY 2016.

Getting fault codes for all glow plugs being open cct and think it is related to the control module. I understand the module is part number AB3912B533AB and ordered the part from Autodoc. On receiving the part it's clear they sent the same part number but its a different version. As per the picture below it seems there is more than one version of this part and I'm struggling to find the one I need (top image). Can anyone help me source one or advise an alternative as Ford want £140 !!!
 

Attachments

·
Registered
Joined
·
1,620 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I did some digging and the BB seems to refer to the complete module including bracket and fixing (as a kit). From here its appears as though there are sub numbers for the 2.2L 4cyl and 3.2L 5cyl though I can't for the life of me find a suppler of the one I need other than FoMoCo and their piss taking prices.

Not too keen on second hand but might have to go that route.
 

·
Registered
Joined
·
1,620 Posts
Can you connect the 'wrong version' (with some bits of wire), see if that clears the code, otherwise it may point to a wiring fault rather than a module
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Totally feasible but I don't have any schematics. A wiring fault is possible and I'll bell everything through if I have to drop £140, I was hoping for a quick £40 fix or simply return the part if it didn't clear the issue (lazy I know but quick).

That said I'll open the thing up and attempt to repair myself before sending £140 to FoMoCo.
 
1 - 5 of 5 Posts
Top