Ford Automobiles Forum banner
1 - 7 of 7 Posts

·
Little Megger
Joined
·
26 Posts
Discussion Starter · #1 ·
Hi there.
I picked up my first Mondeo this morning. A Mk2 P reg 1.8 Deisel LX. Everything seems fine apart from the rear window de-mister does not work, or the front heated screen. I am guessing the are probably both unrelated. The switches light up when pressed, bu there is no heat.
Has anyone got any ideas of what is likely to be wrong? Any known issues? Know places for loose wires etc?
One other problem is that the drives seat seems to be very loose. The back sections wobbles around. Can anyone tell me if this is a usual problem?

Any advice would be very greatfully recieved.

Kind regards,

Howard.
 

·
It was 49.95
Joined
·
10,123 Posts
Welcome to mondeo ownership howard!

With regard to the screens problem, I've known connectors to come off easily on the back screen. They are like spade connectors so check them first. If i remember correctly, the buttons wont light up if the relay, fuses or switches are broken so i dont think that would be your problem. The front heated screen does however have a common problem with the connections corroding. If you look at the battery theres a square pack on the side, give it a good blast with WD40, also there are connections inside the wings which can be accessed easily by removing teh scuttle panel under the screen. Again a good blast with WD40 is a safe bet here.

The drivers seat on mine wobbles a little but not as serious as you seem to describe. There are securing bolts and it may be worth giving them a tighten. including the bolts for the base of the unit to the cars floor.

Someone will be along shortly with better knowledge with me, but I hope what ive said makes some sense
 

·
Registered
Joined
·
3,032 Posts
thelongmile said:
Welcome to mondeo ownership howard!

With regard to the screens problem, I've known connectors to come off easily on the back screen. They are like spade connectors so check them first. If i remember correctly, the buttons wont light up if the relay, fuses or switches are broken so i dont think that would be your problem. The front heated screen does however have a common problem with the connections corroding. If you look at the battery theres a square pack on the side, give it a good blast with WD40, also there are connections inside the wings which can be accessed easily by removing teh scuttle panel under the screen. Again a good blast with WD40 is a safe bet here.

The drivers seat on mine wobbles a little but not as serious as you seem to describe. There are securing bolts and it may be worth giving them a tighten. including the bolts for the base of the unit to the cars floor.

Someone will be along shortly with better knowledge with me, but I hope what ive said makes some sense
Sorry to hijack but when u say securing bolts, are there any in the st seats and where are they?? are they the 6 bolts what go to the floor??
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top