Ford Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all,

I've tried to replace the ICV on my 18.lx mondy but when I put the new one on the car acts as if it doesn't know its there!!

I've tried resetting the on board using my OBD-II before fitting the new ICV and after fitting it!.....but still nothing. It starts fine and the initial revs spike as per usual but as the revs drop instead of stopping at the idle point it just runs down and stops. Put the old ICV back on and it drops down to the faulty point......so it's not an issue elsewhere.

But I've read on other forums, for other makes, that:

1. it could help to disconnect the battery for an hour and then the ECU will reset and see the new ICV

2. Turn the ignition on for 10 secs, then turn off and repeat 3 times without starting the engine and the ECU will see the new ICV

Any ideas??

cheers

Dairin

*frustrated and annoyed of devon!!!
 

·
Big Megger
Joined
·
2,886 Posts
dont see many posts about faulty idle air valve, wouldnt hurt to have a look at your tmap sensor to make sure its clean, also check your butterfly adjustment on the throttle body hasnt been messed with.

air leak can cause idle problems also, throttle position sensor can be tested but they are pretty bullet proof.
 

·
I might like Fords
Joined
·
1,691 Posts
Is it a new ISCV? Genuine part?

I've had a few ISCV playing up on these.

If there are no faults, no air leaks and fuel pressure correct then that's all your left with!
 
1 - 3 of 3 Posts
Top