Ford Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi there, I'm looking for some help with a couple of issues.

This is my second 2011 Mk2.5 1.6 TDCI (the first was written off a couple of years ago by some f**kwit running a red light!) and there are a couple of issues.

Compared to my first Focus this one is slightly sluggish on acceleration and loses power on long steady inclines.

The EML is on and Forscan reads this as P042F EGR valve stuck closed.

I've back probed the connector and have the following readings:

Pin 5 ground - checked for continuity to good earth - OK
Pin 4 0.5v with both key on/engine off and when idling
Pin 1 4.99v both key on/engine off and idling
Pin 2 2.74v with key on/engine off. Drops to 0.01v when idling and does not change with fast idle
Pin 3 0.00 with key on/engine off. With engine on it initially climbs to 13.87v and holds for about 10 seconds until drops back to 0.001v and does not change with fast idle.

I've previously replaced the EGR (before checking voltages!) and would like to get this resolved (I don't want to have it mapped out).

Other than the issues described the car runs OK, consumption is good at about 60mpg. I've previously replaced the turbo due to the usual oil leak and everything else appears sound.

Any thoughts about the EGR and what I need to investigate next?
 

·
Registered
Joined
·
28 Posts
valve might be stuck, have you removed and checked its operation, pretty sure with forscan you can activate it and you should hear the engine change note or stall, cant remember which
 
1 - 3 of 3 Posts
Top