Ford Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hi there got this really annoying problem with my Mondeo 2011 2.2 titanium sometimes when i start the engine the boot opens sometimes , i replaced the boot switch and mechanism .nether worked , the problem seems worse when the weather is really cold ,i have noticed that disconnecting and reconnecting the battery works for a few weeks ,but eventually the problem reappears, the work around i found is setting the central locking to only open the drivers door ,then start the engine ,trouble you got then is you got to open the rest of the doors for other passengers by the door handle as there's no door unlock switch on my car ,which i find very strange. the reason im writing on here is ive seen a few threads with the same problem and i was wondering if you found a fix for this problem??
 

·
Registered
Joined
·
1,634 Posts
I would check that the battery cables are clean and tight on the posts, the other ends of the cables are similarly well connected. Look at replacing the battery if it's old.

Logic:
The body control module (BCM) normally opens the boot when it detects zero volts on the boot switch. If your battery is bad or badly connected then maybe the voltage drop caused by hundreds of amps (especially when cold) going to the starter is enough to trip the BCM.

This isn't a definitive answer and I'm not suggesting you splash out ~£150 on a new battery without checking voltages etc.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Yeah , i agree about the battery ,but had a new battery fitted a couple of months ago , as its getting colder i think the voltage is lower ,think the short journey's dont help , hop its not the BCM i was told £400 .thanks again for the info
 

·
Super Moderator
Joined
·
30,019 Posts
I had it happen once when driving the car home the day I purchased it. It would give a battery low warning with the
engine off but radio on.

Swapped out to a Yuasa battery and not more battery warnings or boot opening itself. Maybe a coincidence but as Master
suggested the battery also it maybe a thing.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I had it happen once when driving the car home the day I purchased it. It would give a battery low warning with the
engine off but radio on.

Swapped out to a Yuasa battery and not more battery warnings or boot opening itself. Maybe a coincidence but as Master
suggested the battery also it maybe a thing.
Yuasa battery are pretty good aren't they ?
 

·
Super Moderator
Joined
·
30,019 Posts
Normally I buy the Bosch S5 batteries, the larger size that will fit. I did actually fit one to this car but
it was the first battery that needed to be charged before use. I always stick them on charge and they
normally show fully charged very quickly but that one was still charging hours later.

Lost confidence in them so purchased the Yuasa and have not had any issues at all, voltage seems
a little higher than the Bosch one also. Have they cust costs on the S5 batteries or is the MK4/4.5
a little fussy on voltages?

Yuasa is now my first choice rather than the Bosch S5.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Normally I buy the Bosch S5 batteries, the larger size that will fit. I did actually fit one to this car but
it was the first battery that needed to be charged before use. I always stick them on charge and they
normally show fully charged very quickly but that one was still charging hours later.

Lost confidence in them so purchased the Yuasa and have not had any issues at all, voltage seems
a little higher than the Bosch one also. Have they cust costs on the S5 batteries or is the MK4/4.5
a little fussy on voltages?

Yuasa is now my first choice rather than the Bosch S5.
brilliant, thanks for the info
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
also i forgot to mention is that if i got all the doors unlocked and the boot opens on start up the hazard lights come on !! ,is that just another warning in addition to the boot open warning on the dash ? also i mentioned earlier that ive set my central locking to just open the drivers door , but on occasions the hazards come on then as well when i start the engine , do you think that is still linked to battery or BCM or both ?
 
1 - 8 of 8 Posts
Top