Ford Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi everyone!

The question is already in the topic. If you looked at the linked picture below, am I missing any fuses in the engine fusebox? The car came like this and I've been using it for almost three years with no issues, but I recently checked the fuse bays and their meaning through this link: https://www.fordwiki.co.uk/index.php?title=Fuse_%26_Relay_Information

and I see that number F3 fuse is a - 60A - Diesel Engine Heater. I, at least, have never had a fuse there. Is that OK? My Mondeo is one of those that has all the higher specs cabling installed, so is there a possibility there is a heater system that is simply off cos of a missing fuse? What would happen if I pop one in there? Any risk of damaging something?

Anyway, here is the picture of my fuse box. Any suggestions gladly welcome:


Thanks!
 

·
Super Moderator
Joined
·
31,104 Posts
F3 = The auxiliary coolan heater...

One of these fitted down on the bulkhead...



The same fusebox is fitted to petrol and diesel cars, as well as different spec vehicles.

So plenty of missing fuses and relays will be normal.
 

·
Registered
Joined
·
5,525 Posts
Not all cars had the electric aux heater installed. Etis will say if yours did, if you can get past the registration stuff (not tried it since that was introduced).
 

·
Super Moderator
Joined
·
31,104 Posts
Still works, but they get you to change password quite often now.

Previously not changed mine for years.
 

·
Registered
Joined
·
5,525 Posts
Never set one up, just used the bits you didn't need to sign in for (spec really). Is it free?
 

·
Super Moderator
Joined
·
31,104 Posts
Yep free.
 

·
Registered
Joined
·
5,525 Posts
:)
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top