Ford Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have been working on cars for over 30 years. But this vehicle has pushed me to my limits. It has blown up and almost at the point of just taking it to the deal and give them the keys and tell them to fix it.

So we were just driving around and I pulled into a gas station with the foot on the brake. The brake pedal just dropped pretty much to the floor. Immediately thought we had sprung a leak. No leak.

No DTC. Interesting.

We carried on. There was still braking ability. Got home ok.

Initially thinking it was the master cylinder. Tested it. No it is good.

Then I was concerned it may have been the brake booster. It seemed ok. More on this later.

Come across the issue with the hydraulic control unit problem which these vehicles have. Could not get it to free up the valves by doing the back up and slam on the brakes, as some seem to have been lucky with.

Ended up buying a new one. Wasn't going to try a used one. Attached the existing module and installed.

Did the initial activation for the new pump which seemed to work.

Scanner shows that the ABS is Inactive. Ok?

Hard to deal with when you have no DTC to lead you.

I carried on with bleeding the system.

We have bled the abs with the scanner, and then down to the wheels. But the pedal still travels almost to the floor.

I am thinking it may have been the brake booster, after testing it again one of the valves internal may have gone.

Check valve is fine.

The diaphragm is fine. I can get vacuum on it. But when I push on the pedal it exhausts almost all the vacuum.

I am hesitant to go changing the booster.

Now the issue is the vehicle has gone into Factory Mode. And I cannot find how to get it back to Normal Mode. Is this what is causing the ABS to be inactive?

Hopefully some out there can lead me into the right direction.

Thank you
 
1 - 3 of 3 Posts
Top