Ford Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
I have a similar problem with my aircon on my mk1 v6 si but a colleague of mine a refrigeration engineer checked it and at first there was no gas so he weighed in the correct amount on the sticker 740 I think the green light comes on when you put the air con on but no click from the compressor he said he is happy it is holding pressure ok as he put a vacuum on for a while b4 re gassing anybody any ideas he seems to think the compressor is ok it is whatever operates the clutch is there a fuse anywhere I could check cheers
stu
 

·
MEG Commander
Joined
·
6,006 Posts
Theres a few other things that could be faulty, the pressure cycling switch, the dual pressure switch and the wide open throttle relay. You can check the compresor by putting a live feed direct to it, if the clutch engages ok then one of the relays or switches mentioned above is faulty.
The fuse on the system is the same one as for the heater blower, number 37 - 30 Amp.

Steve
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #4 ·
sorry to sound a bit thick but could you give me an idea of where the switches and relay are I think one of the switches is down on the n/s at the front ?? :stupid:
 

·
MEG Commander
Joined
·
6,006 Posts
Yep thats the dual pressure switch, the other switch is on the pipework on the other side of the car near the accumulator and the wide open throttle relay is in the engine fusebox, off the top of my head it's on the left hand side the relay above the 3 fuses, I'll double check when I find my Haynes manual.

Steve
 
1 - 5 of 5 Posts
Top