Ford Automobiles Forum banner
1 - 3 of 3 Posts

·
Little Megger
Joined
·
56 Posts
Discussion Starter · #1 ·
Hi.
Just had an interesting experience with my Mk 3 Ghia-X. Car has now done 160k and begining to suffer minor problems. Latest was intermittent soft feel to footbrake with accompanying ABS light showing. An odd sharp metalic sound could be heard on occasions. Jacked up front wheels and found nearside hub was loose (about two turns) allowing edge of disc to touch caliper frame. Fitted new locknut, to be safe, then tightened and torqued to 214lb.ft. No problem for about 3k miles then same thing happened. Took to main dealer who diagnosed front wheel bearing breaking up and rotating in hub. This had caused hub nut to unscrew as the wheel on nearside rotates counterclockwise. Hub had to be replaced as very worn internaly. New bearing and hub with fitting cost me £230, as no time to do myself.
The hub nut used is a four segment 'block' type, which is supposedly self locking and can be used up to four times. I don't trust them now and advise anyone with similar brake symptoms to check hub nut for tightness and investigate further! Could be nasty if hub came off or seized. No obvious explanation for bearing failure, but I did side swipe kerb hard a few thousand miles back. Has anyone experienced similar problem?
Kayball
 

·
MEG Corporal
Joined
·
801 Posts
bearing sliding in the knuckle bed?
i think someone had replaced the bearing badly and damaged the bed and the bearing. caused overheating and so on...
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top