Ford Automobiles Forum banner
1 - 8 of 8 Posts

·
MEG resident lightbulb changer
Joined
·
1,038 Posts
Discussion Starter · #1 ·
My speedo stopped working this morning while I was driving to work, so I assume it has snapped or something.
I'm gonna try and fit it myself, does anyone have an idea of how much a new speedo cable would be??
Its for a mk( details in sig)

Cheers! :L
 

·
It was 49.95
Joined
·
10,123 Posts
speedo cables are fairly cheap mate, around 15 quid iirc, fords want about 20 quid for the cable and 20 quid for the sleeve but intermotor, lds, GMH will all do them for cheaper
 

·
Ugly Little Mo Fo
Joined
·
3,428 Posts
the speedo cable is in 2 parts now m8 and you need a bit of modifying behind the speedo to get the cable to fit.

when i got mine the nice man at ford :surprised: printed out the page from tis for me to follow the instructions for fitting.

:thumbup:
 

·
MEG Commander
Joined
·
6,006 Posts
Dont just assume it's the speedo cable it could be a stripped or sheared gear in the VSS on top of the gearbox (I made the same mistake once) The speedo cable takes it's drive off the top of the VSS but if the gearwheel inside is knackered then it wont work.

Steve
 

·
MEG resident lightbulb changer
Joined
·
1,038 Posts
Discussion Starter · #5 ·
Before the speedo stopped working there was a grinding noise coming from behind the speedo, which got worse after a while. (don't know if that helps determining what it might be?)
 

·
MEG resident lightbulb changer
Joined
·
1,038 Posts
Discussion Starter · #6 ·
just checked the haynes manual to see how to remove a speedo cable, and it said that at one point you have to jack up the car and put it on axle stands. Do you have to do this? or is it just to make things easier. Also don't you have to take the clock out to disconnect it from them??
 

·
MEG resident lightbulb changer
Joined
·
1,038 Posts
Discussion Starter · #8 ·
I'll check that out, if it has just slipped out then I could save myself some money :D.
Got more serious problemsat the moment, I think my thermostat has gone coz the engine is running very hot so gotta sort that out first asap.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top