Ford Automobiles Forum banner
1 - 5 of 5 Posts

·
Big Megger
Joined
·
144 Posts
Discussion Starter · #1 ·
Was playing about with fuse box other day on my 2.2 and notice that the instrument cluster is fused on its own. Curiosity got the better of me and found out with fuse out speedo along with other gauges stopped working, cruise still worked but no indicators which seems loigical. Made me think how many motors going up down country with no indicators working!!! Sorry if this has been covered in previous thread.
 

·
Just me
Joined
·
19,673 Posts
Does that mean it does not add to the mileage?
 

·
TDDI Buff
Joined
·
37,060 Posts
i would think it dosent given the subject, dodgy!!
 

·
Big Megger
Joined
·
144 Posts
Discussion Starter · #4 ·
It does indeed mean that:(:( just makes my blood boil things like that although maybe there is another type of memory or something that gives the game away when it goes in for service, what a laugh that would be when service guy says to them "have you got a min pleaase sir" :L hoist with their own petard i would say:)
 

·
Registered
Joined
·
103 Posts
have you taken the fuse out and driven the car. we had a fuse blow and when you put the ignition on the clocks and guages wouldnt work for about 20 seconds on start up , but started working after the delay. i remember a story in the local rag a while back about toyota carinas where if the fuse was taken out you also lost the electric windows.... quite a few red faces at the toyota garage,,,it was an x employee who let the cat out the bag.
 
1 - 5 of 5 Posts
Top