Ford Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone, I'd like to pick your brains. We just bought this 2010 Galaxy tdci 163hp model with a known fault which is lack of power. I've read the codes with forscan mobile app and it comes back with p0234. I attach a screenshot of the fault. I already cleaned the MAP sensor, checked the dpf, it seems to be ok. What else shall I check, what tests can I carry out to find the root of the problem? I also have an issue with the tyre pressure monitoring system, screenshot attached. Is anything I can do about it? It looks like the front right parking sensor has an open circuit, does it mean it is time for a new sensor? Is it a bumper off job?
Thanks in advance!
 

Attachments

·
Super Moderator
Joined
·
29,780 Posts
Split boost pipe or EGR fault?

What boost pressures are you getting?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Split boost pipe or EGR fault?

What boost pressures are you getting?
Thanks Purple for the reply. The EGR is blanked. Is there a common place for the boost pipes to split?
I've just logged the manifold pressure on our way home. It was reading between 0.95 bar and 1.5 bar, after the engine malfunction lamp came onto the screen it never went over 1.2 bar.
I've also noticed that sometimes when I release the accelerator and the car is rolling with engine brake only, the MAP sensor reading dropped to 0.98 and after it it built up to 1.3. Is that ok?
 
1 - 3 of 3 Posts
Top