Ford Automobiles Forum banner

ODBC errors detected

2924 Views 9 Replies 4 Participants Last post by  pauldb38
Hi wonder if you can help me i have a mondeo 1.8 mk2, and recently i noticed the MPG have gone down and also theres slight hesitation when accelerating. So i thought i would run a scan with my elm interface and this is what i found.

First error was

1. P0171
Powertrain: Fuel Trim System Lean Bank 1
then i was going threw the tests and got this error message .....

fuel system 1 status
ol - fault: open loop due to detected system fault ol/cl

Does this mean a sensor isn't working ? What do i need to rectify this ?
1 - 10 of 10 Posts
first i suggest you jack up each wheel and chock the one on the ground and release the handbrake and check the wheels for free movement as if the brakes are binding this would explain the hestiation and poor fuel economy without fault code reader ever being used...x
some reasons for the lean condition from various sources...

A lean fuel condition may exist if the engine is sucking in too much air and/or the fuel system is not delivering enough fuel. a lean fuel condition may cause lean misfire, a rough idle, hesitation or stumble when accelerating, and/or poor engine performance.
Unmetered air can enter the engine through a vacuum leak, a dirty airflow sensor that is not reading airflow accurately, an EGR valve is not closing and is leaking exhaust into the intake manifold, an EGR valve that is allowing too much flow (because the EGR differential pressure sensor that monitors EGR flow is faulty and is under-reporting EGR flow).
If the problem is not enough fuel, the underling cause may be a weak fuel pump, restricted fuel filter, leaky fuel pressure regulator or dirty fuel injectors.
See less See more
hi your problem is more likely to be the lamber sensor is faulty as what happens is it goes wrong and then tells the ecu that the engine is running to lean so it puts in more fuel than the engine needs so over fueling it thus causing the engine to hesitate and also high fuel consumption

I have just bought a new lambda sensor and fitted it last week as i thought the same , i also took the positive lead of the battery and left it over night to reset the ECU so the error should have cleard ???? Then i have run it for about 5 days then connected the ELM 327 and it read the error. I have cleared it and will run for another week and see how we go but MPG is about 24mpg atm which is very poor ....
have you checked the vacum hoses for leaks also the pipe that goes from just under the rear of the coil pack to the inlet manifold as this is prone to colapsing or splitting
Well i'm not sure if i have cured the MPG issue but i did have a good look around and theres a vacum pipe that goes from the back of the engine to near the front that was completly off ,i think it goes into the LPG vapourizer as there was what appears to be a spare terminal for a a pipe. If i put my finger on the pipe it was sucking in air and the engine nearly stalled so maybe just maybe that has cured the problem , will get he computer on it to see if we are still getting error codes.

Do you think it might be worth reseting the ECU ?
i would reset the ecu then it will clear the codes so when it goes back on the code reader you will know if its cured the problem as if it has then it sould not show up any fault codes
I will recet the ecu but i still have a problem just as i thought it was ruuning sweet as well.

When starting from cold its great smooth and everything but after 3 miles or so when i pull up to a junction the idle goes up and down like a lift on steroids , i'm just wondering if a vacume pipe is failing when the engine gets hot ? Where can i get replacement pipes ? Maybe upgrade them to something better ?
well well well what a turn up for the books reset the ECU but i couldn't understand that when the engine started to get temp the idle was up and down at traffic lights i sounded like a boy racer.
Checked pipes over and over again but couldn't find a leak anywhere. So i thought with the low MPG i wonder if the Cat was blocked, so i took it to ur local exhaust repair centers as my exhaust is still under warrenty, it came back as fully working. But the engineers said you do know your only firesing on 3 cylinders :tonofbricks:

So took the spark plugs out the first one i took out looked very clean and i thought well if the other 3 look as good as this it aint a problem with the plugs, but the other 3 was black , cleaned them up checked spaces etc but still the same problem , So time to check the spark argh no spark on the very clean plug , swopped HT leads round still no spark , changed spark plugs round still no spark. I rulled out the coil pack because i replaced this about 18 months ago but i bought it from ebay new hmm cheaper don't better value , so looks like i need a new coilpack this time i'm buying a motorcraft one lol.
See less See more
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.