Ford Automobiles Forum banner
1 - 7 of 7 Posts

·
Big Megger
Joined
·
243 Posts
Discussion Starter · #1 ·
i was jump starting a friends old car the other day and i got the battery points round the wrong way (slap me for being so thick). now my radio doesnt work. i have tried my radio in another car and it is working. so i suspect a fuse or something like that anyone know where the fuses are for the radio??
 

·
MEG Commander
Joined
·
2,969 Posts
pull your glove box out, look up and you will see the passenger fuse box :)
 

·
Big Megger
Joined
·
243 Posts
Discussion Starter · #3 ·
checked al of my fuses and they r ok there is one i am unsure about it is a long fuse that you cannot see through could this be it???

also you could have told me that you can drop the fuse box down got half way through without realising. (my fault for being thick)
 

·
irishghiax
Joined
·
798 Posts
just had a look in my owners book & it says fuse number 32 is for the radio,it should be brown & 7.5amp.this is for a 1998 mondeo & is found in the glove box fuseboard :L .
 

·
Big Megger
Joined
·
243 Posts
Discussion Starter · #5 ·
what would be thenext thing to check if it is not the fuse???
 

·
MEG Commander
Joined
·
2,969 Posts
surely it would be the fuse on your radio, or its just broken. :)
 

·
Big Megger
Joined
·
243 Posts
Discussion Starter · #7 ·
but my radio works in another car and the one out of the other car doesnt work either
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top