Ford Automobiles Forum banner
1 - 5 of 5 Posts

·
Big Megger
Joined
·
208 Posts
Discussion Starter · #1 ·
Its been along time since my last post on the mondeo forum, and this is relating to my escort but i believe the zetec engine in my escort is about the same as the zetec in mondeos hence my post here...

When starting the car from cold it will over rev - sometimes just under 2000rpm I know this isnt right, when the car is at normal operating temp (say after a 30 min - 2 hr drive) it will still be over reving say about 1200 rpm i think it should idle about 800 ish.

If when the car is at norm operating temp and i switch off the engine - then restart it will idle at 800, and will stay at that speed. Should i then drive upon comming to a stop and then the engine idling again it will be over reving - about 1200 rpm.

I think it could be the MAF? I remember reading somewhere that these need replacing or cleaning but its a long time again, is there any way i can test it?

extra info.. car is an 'N' reg escort 1.6LX 16v 112K miles, it does not misfile stall etc and is a good drive apart from the over reving.

Thanks for any help that can be offered. Ian.
 

·
Still waiting to Wii
Joined
·
2,710 Posts
Idle control valve comes to mind, they can be faulty
 

·
Big Megger
Joined
·
208 Posts
Discussion Starter · #4 ·
This morning (damp conditions - the car is left outside each night) it started and idled fine, until i got to work then it idled too fast again.
 

·
Registered
Joined
·
205 Posts
Take the idle control valve off and give it a good spray with carb cleaner (or soak in petrol) then try it.

Also disconnect the throttle cable at the throttle body end, then pull the cable back andforth to check its nice and free.

If neither of these work test the TPS as per haynes manual.

If your still struggling check all round the inlet system for air leaks
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top