Ford Automobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My 2.0 TDCI Zetec 52 plate. The temperature guage keeps shooting off to the max on the range but the water bottle is at correct level and the fluid in it feels cool and the fans are coming on but no hot air in the cabin area.
Can anyone help please.
 

·
MEG Sergeant
Joined
·
1,667 Posts
Sounds like your Theromstat is stuck closed, you need to fit a new one they are about £10 from Fords and take about 10 mins to fit.

You will also need some coolant to replace the amount you lose when removing the thermostat.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Checked Thermostat and it was not working so changed it, still no change no heat in car and temp keeps rising then drops slightly then rises again and so on. Thermostat from Fords was £31.
Tried the filling of the cooling system as detailed in the Haynes manual:.. Pump bleed then running but level in cooling reservoir does not seem to drop much. This is starting to look expensive.
Thanks for the first pointer and I hope you can help me further.
Bob :thankyousign:
 

·
MEG Sergeant
Joined
·
1,667 Posts
It must be an Air pocket in the cooling system then, not to sure if your Mondeo has any bleed valves but I would run the car till warm open the cooling tank (SLOWLY) and squeeze the big black pipes that go from the cooling tank to the engine with the cap off.
Then replace cap and see.

Air pockets are sometimes a pain and it may take doinjg this a few times.

Keep us posted.
 

·
Registered
Joined
·
32 Posts
My 52 plate has just a a new water pump - same symtoms - no heat in the cabin, engine overheating. I tried the thermostat first too, but made no difference. The water pump was working partially so was quite difficult to pinpoint the problem. I paid £175 to get a new pump fitted, think pump itself was £80.
 
1 - 6 of 6 Posts
Top