Ford Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
Keep getting there 2 codes pop up and engine malfunction on the dash. I have only managed to clear it once with forscan. But came back after 5 minutes of driving. Now the engine management light will flash but it come straight back if I try reset it. With Car coolant temperature over 80oC
I tried to do a dpf regen with forscan.
it will start get to 2% revving up then engine malfunction will come on dash. I have to leave it to the end of the 20 minutes it will say complete. Obviously it hasn't.
I had to rewire my coolant fan because of broken pink purple wire by the fan plug. It works when temp gets to 98 but doesn't work when I put Aircon on. Don't know if that's related
What are the main cause of these 2 codes that I should be looking out for?
 

·
Super Moderator
Joined
·
31,063 Posts
Possibly not detecting the cooling fan coming on, think thats one of the safety checks it does.

What year is the car? Can you see the soot loading figures? I have a facelift car and there are 3
separate soot load readings.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #3 ·
2007 forscan gives me a dpf PID that reads in kpa I will have a look properly what it is there 3 other IDs for it think I was temp sensors but they don't read anything.
My cooling fan works when it's gets to 98 temp so I'm guessing it works fine now it never use to work because the broken wire
 
1 - 3 of 3 Posts
Top