Ford Automobiles Forum banner
1 - 8 of 8 Posts

·
Big Megger
Joined
·
321 Posts
Discussion Starter · #1 ·
I've been told before that my car could be running a bit rich and recently I've noticed the fuel economy drop.

Is it likely the lambda/oxygen sensors needs replacing?
How many and where are they on the V6?
Where is best to get them from?
Are they easy to replace?

thanks
 

·
MEG's resident oven
Joined
·
11,381 Posts
possibly them yes, but try cleaning the maf sensor and replacing the air filters etc first. there are 2 on the v6's one on the front downpipes and one on the back set. they can be got to fairly easyish with the right tools but the back is a bit of a pain!

for somthing like that oem is best but expect to pay about 80-100 quied each for them!!
 

·
Big Megger
Joined
·
321 Posts
Discussion Starter · #3 ·
Would a diagnostic tell me if these sensors definitely need replacing?

If I was to get a diagnostic done, is there much difference between going to Ford or buying myself an OBD2 to USB cable and using my laptop?
 

·
Megger
Joined
·
70 Posts
The diagnostics can only tell you what you already know.. car running rich. Buy yourself a handheld ODB II scanner (30 £ max from hong kong) , if you want the webadress of the company I buy mine from just pm me and I will give it to you (I use visa to buy from them and no problems yet)
 

·
MEG's resident oven
Joined
·
11,381 Posts
ford can do a live reading ( inow i had one done on my car) and it shows the lambda patterns. the will know if they are starting to breakdown by the pattern they are producing on the machine
 

·
Megger
Joined
·
70 Posts
Didn´t know this but you can test you lambda sensor with a voltmeter and see what voltage it gives. You just have to know the working voltage of that lambda sensor (I think 0.2 - 0.9 volt switching , it should change value quite often 1-2 times / sec if slower or not changing at all the sensor is on it´s way out) , cheaper than frauds garage :L
 

·
MEG Sergeant
Joined
·
1,246 Posts
Not sure if any help but my ST failed its last MOT on emissions, about 3 times above what they should be, MPG had been pretty steady though.

The garage did a diags on the engine and showed both lamda's had failed, these were replaced and it then sailed the emissions, mine lasted about 120k so if you car is on a similar mileage could be an issue.
 

·
Big Megger
Joined
·
321 Posts
Discussion Starter · #8 ·
The car has done 131k.
It had the MOT done about 3k ago and on the first go the emissions were way too high...but he tried it again and again and eventually they were below the limit, but it took a while to get there. Not sure he should have passed it like that but I wasn't going to moan :)

I'll need to get it booked in for a diag I think.
Any idea how much Ford charge for this?

thanks
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top