Ford Automobiles Forum banner
1 - 14 of 14 Posts

·
Crepello
Joined
·
552 Posts
Discussion Starter · #1 ·
My radio (7000 RDS EON) screen is on the blink ,maybe the cold weather, but its the 2nd one to go like this. What I would apreciate is, what is the best replacement bearing in mind the connected 6cd changer in the boot and compatibility with the remote stalk.
:thankyousign:
 

·
Big Megger
Joined
·
451 Posts
Not as loud, but I changed mine for a 6000 CD, as after 3 7000's and my dads 7000 doing the same, it was time for a change (plus you get a cd player in the front!)

Alternatively, theres a bloke on the bay that sells new 7000 units for about £50 (might be in walnut though, so may need to change the front for your old one).

5000 is the same output as the 6000 but is only a tape, and isnt as good as the 7000 by far, but is a cheap replacement.

All of the above units will take the remote, and the changer.
 

·
MEG Commander
Joined
·
6,006 Posts
I'm on my 3rd 7000, when the displays go I just get another one from Ebay (after checking that the display is ok!) they only go for a few quid as they are pretty worthless without the cd changer, just a tape head unit.
As you say it seems to be the cold weather that kills them off!
Some people on here have had the display screen itself changed.

Steve
 

·
Resident Old Fart !
Joined
·
7,070 Posts
Funny enough i was just about to post a similar fault .. just switched mine off for a couple of hours and came back and no display :( everything is still working as it should but just no display but all funtions working ... Damn it i liked the unit as well lol
 

·
Registered
Joined
·
13 Posts
Hi, Get a 5000N/6000N (with a nob!) off Ebay or someone, they are a straight replacement for the 7000 and they have a better amplifier in them that matches the output power of your 7000. There should be no difference. The 5000T (with a toggle volume control) is not so good as it has a lower power amplifier, but the 5000N (N for nob, T for toggle) is the one to get. Trev.
 

·
Big Megger
Joined
·
379 Posts
This is bizarre, my 7000 display gave up the other day also, took it in the house let it warm up/dry out and it was great for a day then slowly dimmed and went of, haven't seen it for two days now, looks like I'm going to have to replace then!!

I wonder if my wife would notice if I stole the 5000 out of her Fiesta and replaced it with my 7000??

M
 

·
ME
Joined
·
5,869 Posts
My 7000 kept cutting out (connections with the security panel?) I've just replaced it with another 7000 I got off ebay ( had it awhile without installing). The replacement 7000 screen lights up with the ignition but doesn't display any figures etc. so I can't enter the code. Tried reinstalling the original 7000 but when it does decide to work I can't tap in the code because every time I touch the security panel it just goes off and I'm getting nowhere. Any Ideas with the replacement am I doing something wrong or do I need to search for another replacement.
 

·
MEG Commander
Joined
·
6,006 Posts
nilagin said:
My 7000 kept cutting out (connections with the security panel?) I've just replaced it with another 7000 I got off ebay ( had it awhile without installing). The replacement 7000 screen lights up with the ignition but doesn't display any figures etc. so I can't enter the code. Tried reinstalling the original 7000 but when it does decide to work I can't tap in the code because every time I touch the security panel it just goes off and I'm getting nowhere. Any Ideas with the replacement am I doing something wrong or do I need to search for another replacement.
You need to search for another replacement m8, the one you've bought has the common non working display, a tip for when buying a 7000 off Ebay is to always check with the seller that the display works.

Steve
 

·
ME
Joined
·
5,869 Posts
Seller described it as fully working when I got it but I have had it for several months now without bothering to try it, my own fault really.
No music now till I get another replacement.
 

·
Big Megger
Joined
·
379 Posts
Mine came back to life today, I've got it pulled out slightly as I was having the alternator tested yesterday, with the heaters on pointed at it, it came back to life!!! No doubt by tonight it'll be off again.

M
 

·
ME
Joined
·
5,869 Posts
I roasted myself and the stereo on the way home from work this afternoon and screen on my replacement kept flickering on. When I got home I tried tapping in the code but screen kept dying. Got straight on ebay and ordered myself a 5000N replacement. Went back out and the screen worked for me to tap in the code :crazy: Don't know if it'll be working still in the morning though. CD's sounded alot better though for some strange reason. No vibration from the speakers that I was getting from my original stereo. :crazy:
 

·
Resident Old Fart !
Joined
·
7,070 Posts
Just as an update mine has also started working again :crazy: so ive started leaving it turned on, even when i dont want to listen to it .. Just turn it right down and its now working all the time .. Maybe i wasnt using it enough lol
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top