Ford Automobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hey guys,

its been a long time since ive had a mondeo! but alas im back, i picked up a 2005 1.8 petrol mondeo with 179,000 km on the clock.it was driven by an old farmer quite slowly and short trips id imagine.

it was fine on the test drive but i note the car was warmed up a bit before i got there and also he came for the test drive so i couldnt hoon it for fear id give the man heart failure.

anyway i bought it and on the way home when i put my foot down it bellowed black smoke like a diesel! My Mrs said she couldn't see past it while behind me! inside the cabin i noticed a slight rattle when the revs and load where getting up but with gentler acceleration it wasn't really there? more faint. ive pulled the plugs and they are not badly fouled or showing oil deposits the plug gaps where all over the place so i set them all to 1.2mm.

what should i look for here? i topped it off with oil just under 1/2 liter til it got to the upper mark 10w40 is all i had lurking in my shed but i believe 5w30 fully sythetic is what these mondys like thicker oil can upset them?

i have slight issue regards the gearbox very stiff at times to get any gear other times perfect i think i have that narrowed down to failed gearbox mount i will have a new one tomorrow. also on the gearbox it is little low on oil, as in when i pulled the level filler bung nothing came out. i have some sythetic 75w90 gl4 in my shed will this be ok to top it off with?

finally i have a very stiff brake pedal and bad inner edge tyre wear on the drivers side tyre no other tyre has this affliction ball joint? the coolant tank has by the looks of things had rad weld added and i think thermostat is stuck open.

P.S being 2005 my intake manifold should be ok for a few miles yet?

thanks
 

·
Super Moderator
Joined
·
31,663 Posts
Some 1.8's suffered excessive oil consumption, the piston rings get gummed up and sticky.

Later intake manifolds were better but not 100% cured.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
i don't think its burning oil anyway the plugs were far to clean, i think it needs a long jaunt on the motorway to clear out the cobwebs, i have seen a youtube video of Pcv valves and hoses failing. i hope i have the latest revision anyway theres no noise from them yet anway
 
1 - 4 of 4 Posts
Top