Ford Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Long time since ive posted, wondering if you could answer a few questions i have?

1) I have a problem, that has been getting worse, whereby I can press on the gas but the power is not transferred to the wheels? The rev counter goes very high? The best way to describe it is as if you were accelerating with your foot on the clutch?

2) Sometimes, I get a loud clank/thump/bang when I start the engine? This is not always and it will start, any ideas?

3) on the left side of the engine, deepish down I have a belt with some cracks… I think this is the cam/timing belt? Should I get this changed?

Thanks.
 

·
It was 49.95
Joined
·
10,123 Posts
1 ) sounds like clutch gone

2 ) if the clutch is gone it may cause the thrust bearings to knock but unsure

3 ) YES YES YES DEFINATLEY any belt on that side of the engine that shows wear, get it changed immidiatley
 

·
MEG Corporal
Joined
·
866 Posts
The clutch is definately shot.

The belt he can see will be the aux drive belt and they do crack even when fairly new. If the cracking isn't too bad then its safe to leave it and just keep an eye on it. Having said that, if he's going to stick it in the garage for the clutch, he might want to get the belt done at the same time. He might even want to check up on when his cambelt is due.
 

·
Resident LED Guru
Joined
·
2,912 Posts
wont do any instant damage, but as it drives the water pump too, it will overheat and eventually seize. Stop the engine if you suspect that it has snapped
 

·
MEG Captain
Joined
·
4,819 Posts
yes :L
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top